The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mysql-based sites that require logins = DOWN!

Discussion in 'General Discussion' started by dhecker, Jun 12, 2006.

  1. dhecker

    dhecker Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Hello -

    Perhaps someone can help with this urgent problem:

    We are seeing issues in our mysql based sites. We upgraded from 4.0 to 4.1 recently (a few days ago) and that could be related to this problem.

    Suddenly our two phpbb forums aren't working, also our Joomla admin section, and mantis. These are all things that require a mysql password system to work, so I am thinking it's related to the mysql upgrade. I am poking around in the server and everything seems ok - I can even browse the front-ends (without login) of one of the phpbb sites and the Joomla site. So, I suspect this is related to the mysql upgrade, etc.

    If anyone has any ideas about how to get things going again, I would really appreciate it!!

    thanks, Dave
     
  2. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Did you try this?

    Tweak Settings - check
    Use old style (4.0) passwords with mySQL 4.1+ (required if you have problems with php apps authenticating)
     
  3. dhecker

    dhecker Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Hi -

    Thanks for your reply! I did check that box, yes.
     
  4. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    open the /etc/my.cnf and make sure the there is a line that says

    old-passwords

    If not then add it to the my.cnf and then

    service mysql restart
     
Loading...

Share This Page