The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL config error

Discussion in 'Database Discussions' started by Rodrigo Gomes, Aug 16, 2016.

Tags:
  1. Rodrigo Gomes

    Rodrigo Gomes Active Member

    Joined:
    Apr 6, 2016
    Messages:
    26
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Code:
    Error from MySQL query: (XID nbn6sk) Database Error: Can't find any matching row in the user table
    The system could not execute the instructions “GRANT” of user "test123" due to an error: (XID nbn6sk) Database Error: Can't find any matching row in the user table
    This error occurs in several different locations in the cpanel and makes impossible to restore full backups.

    Some places when this error occurs:
    Website Software
    Backup Wizard (during restoration)

    This error disappears when I remove my custom settings in my.cnf:

    Code:
    [mysqld]
    performance-schema=0
    default-storage-engine=MyISAM
    innodb_file_per_table=1
    max_allowed_packet=268435456
    #open_files_limit=10000
    local-infile=0
    
    #
    # CUSTOM
    #
    
    max_connections=250
    wait_timeout=28800
    interactive_timeout=28800
    
    skip-name-resolve
    myisam_use_mmap=1
    
    query_cache_type = 1
    query_cache_size=512M
    query_cache_limit=8M
    
    join_buffer_size=32M
    read_rnd_buffer_size=6M
    max_allowed_packet = 10M
    
    tmp_table_size=256M
    max_heap_table_size=256M
    
    table_open_cache = 9000
    thread_cache_size = 70
    
    open_files_limit=50000
    
    key_buffer_size = 2G
    myisam_sort_buffer_size = 256M
    
    innodb_file_per_table=1
    innodb_buffer_pool_size = 3G
    innodb_log_file_size = 124M
    innodb_log_buffer_size = 9M
    innodb_buffer_pool_instances = 3
    
    # Debug
    #slow_query_log=1
    #slow_query_log_file="/var/log/mysql.slow-queries.log"
    
    But this setting is important for caching the database and relieve the CPU:

    mysql_queries-week.png

    Does anyone have a suggestion on how I can fix this?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you check to see if the issue persists after removing "skip-name-resolve" from your /etc/my.cnf file and restarting MySQL?

    Thank you.
     
  3. Rodrigo Gomes

    Rodrigo Gomes Active Member

    Joined:
    Apr 6, 2016
    Messages:
    26
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    This solved my problem!
    Thank you!
     
    axita shah likes this.
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now resolved. Note that cPanel isn't designed or tested with the skip-name-resolve option in the /etc/my.cnf file, so enabling this option might break certain functionality.

    Thank you.
     
    Rodrigo Gomes likes this.
Loading...

Share This Page