The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mysql connect timeout during daily backup

Discussion in 'General Discussion' started by bwwt, Jun 23, 2004.

  1. bwwt

    bwwt Member

    Joined:
    Aug 13, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Is there a way to stop the mysql connection timeouts I get when cpanel does its backups? It almost always loses connection on my "posts" table in my Vbulletin database.

    I read somewhere that using max_packet_size = 16M would remedy the problem, but I'm sure I already have that.

    Thanks
     
  2. hostseeker

    hostseeker Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    I had the same problem, mine would fail 4 out of 5 nights. Per someone's suggestion on another forum I chagned my.cnf to the following and it has has not failed for 3 straight nights now (keeping fingers crossed):

    [mysqld]
    key_buffer=16M
    myisam_sort_buffer_size=64M
    join_buffer=1M
    record_buffer=1M
    sort_buffer=2M
    tmp_table_size=32M
    table_cache=1024
    thread_cache_size=256
    table_cache=10
    wait_timeout=20
    interactive_timeout=200
    connect_timeout=10
    max_allowed_packet=16M

    I think maybe some of the timeout settings help also as I had previously has the max_allowed_packet set to 16M and also at 32M and it still failed.

    I will let you know after a few more nights if the problem is solved.
     
  3. bwwt

    bwwt Member

    Joined:
    Aug 13, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Great, thanks Hostseeker. I'll give it a shot and see how that goes.
     
  4. No-State

    No-State Member

    Joined:
    Jun 12, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    So how did it go ?
     
  5. hostseeker

    hostseeker Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    After making the changes on my last post the problem still existed about half the time. Then I changed the 'wait_timeout' to 3600 and now it works properly 95% of the time. (still fails about 1 out of 20 times, but I can live with that)
     
Loading...

Share This Page