Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

mysql-connectors-community No more mirrors to try error

Discussion in 'Database Discussion' started by Deker, Sep 30, 2018.

  1. Deker

    Deker Well-Known Member

    Joined:
    Feb 15, 2011
    Messages:
    99
    Likes Received:
    4
    Trophy Points:
    58
    cPanel Access Level:
    Root Administrator
    I'm trying to install cpanel on my new Centos 7 VPS, but getting the following error.
    I did OS reload several times and tried again but still getting same error.
    How can I fix the issue?
    Any help would be greatly appreciated.

    Code:
    2018-09-29 18:45:46  462 ( INFO): The 'mysql-version' key is set to: 5.7.
    The system was not able to ensure the availability of the âcoreutilsâ/usr/bin/yumâ1â
    T                                                                                   Trying other mirror.
    
    
     One of the configured repositories failed (MySQL Connectors Community),
     and yum doesn't have enough cached data to continue. At this point the only
     safe thing yum can do is fail. There are a few ways to work "fix" this:
    
    
         1. Contact the upstream for the repository and get them to fix the problem.
    
         2. Reconfigure the baseurl/etc. for the repository, to point to a working
            upstream. This is most often useful if you are using a newer
            distribution release than is supported by the repository (and the
            packages for the previous distribution release still work).
    
         3. Run the command with the repository temporarily disabled
                yum --disablerepo=mysql-connectors-community ...
    
         4. Disable the repository permanently, so yum won't use it by default. Yum
            will then just ignore the repository until you permanently enable it
            again or use --enablerepo for temporary usage:
    
                yum-config-manager --disable mysql-connectors-community
            or
                subscription-manager repos --disable=mysql-connectors-community
    
         5. Configure the failing repository to be skipped, if it is unavailable.
            Note that yum will try to contact the repo. when it runs most commands,
            so will have to try and fail each time (and thus. yum will be be much
            slower). If it is a very temporary problem though, this is often a nice
            compromise:
    
                yum-config-manager --save --setopt=mysql-connectors-community.skip_if_unavailable=true
    
    failure: repodata/repomd.xml from mysql-connectors-community: [Errno 256] No more mirrors to try.
    http://repo.mysql.com/yum/mysql-connectors-community/el/7/x86_64/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for mysql-connectors-community: Damaged repomd.xml file
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,469
    Likes Received:
    505
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Deker


    What's the output you get when running the following:

    Code:
    curl -v http://repo.mysql.com/yum/mysql-connectors-community/el/7/x86_64/repodata/repomd.xml
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice