The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mysql CPU and Memory- FEDERATED disabled

Discussion in 'General Discussion' started by marnslee, Dec 6, 2011.

  1. marnslee

    marnslee Registered

    Joined:
    Apr 19, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Good afternoon, I have been having problems with out cpanel VPS and mysql, I am noticing that the process manager is showing /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --log-error=/var/lib/mysql/(our vps name).err --pid-file=/var/lib/mysql/(our vps name).pid with the following in it after /etc/init.d/mysql restart:

    I suppose my main questions is why is Plugin 'FEDERATED' is disabled and will this cause a problem?

    111207 13:37:13 mysqld_safe mysqld from pid file /var/lib/mysql/cpanel.webandmore.com.au.pid ended
    111207 13:37:14 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    111207 13:37:14 [Note] Plugin 'FEDERATED' is disabled.
    111207 13:37:14 InnoDB: Initializing buffer pool, size = 300.0M
    111207 13:37:15 InnoDB: Completed initialization of buffer pool
    111207 13:37:15 InnoDB: Started; log sequence number 1 3931089477
    111207 13:37:15 [Note] Event Scheduler: Loaded 0 events
    111207 13:37:15 [Note] /usr/sbin/mysqld: ready for connections.
    Version: '5.1.56-log' socket: '/var/lib/mysql/mysql.sock' port: 3306 MySQL Community Server (GPL)

    can anyone shed some light on this please. I have modifed my.cnf with mysqltuner and have it running as well as I can. see below

    [mysqld]


    key_buffer_size = 48M
    max_allowed_packet = 1M
    table_open_cache = 24576
    sort_buffer_size = 2M
    read_buffer_size = 2M
    read_rnd_buffer_size = 2M
    myisam_sort_buffer_size = 256M
    thread_cache_size = 8
    query_cache_size = 256M
    query_cache_limit = 1M
    innodb_buffer_pool_size = 300M
    join_buffer_size = 12M
    max_connections = 125
    max_join_size = 4294967295
    connect_timeout = 15

    # Keep the 2 below the same:
    tmp_table_size = 16M
    max_heap_table_size = 16M


    slow_query_log = 1
    long_query_time = 3
    # log_queries_not_using_indexes = 1
     
  2. marnslee

    marnslee Registered

    Joined:
    Apr 19, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    sorry, a point I had not mentioned is that php users & mysql are using a lot of %cpu and %mem, below is the data for top

    top - 14:13:16 up 20 days, 15:30, 1 user, load average: 0.49, 0.93, 1.03
    Tasks: 140 total, 1 running, 139 sleeping, 0 stopped, 0 zombie
    Cpu(s): 0.5%us, 1.0%sy, 0.0%ni, 98.0%id, 0.0%wa, 0.0%hi, 0.5%si, 0.0%st
    Mem: 4044636k total, 3802732k used, 241904k free, 221596k buffers
    Swap: 6088624k total, 80k used, 6088544k free, 2539888k cached
     
  3. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    386
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Hello,

    The warning is safe to ignore, if you don't have a federated table on the server. Pleaes find the details in the following URL

    MySQL :: MySQL 5.0 Reference Manual :: 13.7 The FEDERATED Storage Engine

    If you would like to enable this, add "federated" into my.cnf under mysqld section.

    Also, I don't see anything unusual in the top output. The resource usage and load seems to be fine!

    Thank you,
    Nibin.
     
Loading...

Share This Page