Mysql CPU usage too high at same time daily

adias

Registered
Jan 27, 2014
3
0
1
cPanel Access Level
Root Administrator
I have a big problem with my server. Every night at 2:00 AM is going down for 20-30 minutes. After many investigations mysql looks to be the problem.

I have :
CentOS release 6.5 (Final)
WHM 11.40.1 (build 9)
5.1.72-cll MySQL Community Server (GPLv2)
A good server configuration

What I did:
- first I thought is to much traffic and I did all kind of optimizations for apache and mysql (mysqltuner.pl , tuning-primer.sh and so on). The problem is not here. I have about 200-300 visitors instantly and the load is : average: 0.26, 0.35, 0.35 . At the midnight when all services are down and is a high load are around 80-100 visitors

- then I read about backups - so I disabled all kind of backup

- crons - disabled all crons , stop crond service , removed all crons from cron.daily

- stop all automatically check for updates and put everything on disable or manually update

- I put this values on WHM at Configure cPanel Cron Jobs : upcp 0 0 1 1 * and cpbackup 0 0 1 1 *

- disabled services like Analog,Awstats, Logaholic, Webalizer

- enabled slow queries and verify each log for mysql, messages, etc

- all databases optimized

- no I/O problems

So at the end I think is still a cron somewhere or something. Like you see on attached image mysql is going crazy . If I stop mysql before 2:00 AM with few seconds then start again after few seconds and everything is normal.

Any suggestions ?
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Check the output of the following command when MySQL is under heavy usage:

Code:
mysqladmin processlist
This should provide information about which databases are using up your resources.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
At the end was an wordpress plugin : Wordpress Popular Posts . Thanks a lot for help.
I am happy to see you were able to determine the cause of the issue. Thank you for updating this thread with the outcome.