The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mysql encoding problems

Discussion in 'General Discussion' started by makkintosh, May 24, 2006.

  1. makkintosh

    makkintosh Member

    Joined:
    May 24, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    hi all
    i have problem with encoding.
    today are expreriencing problems with encoding.
    on all our websites there are question marks instead of cp1251 text.
    only SET CHARACTER SET cp1251 helps. but it is not the right way to solve this problem!

    what should i do?
    i dont want to edit all configuration files on all websites on my server.
    thanx
     
  2. makkintosh

    makkintosh Member

    Joined:
    May 24, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    by the way it happend ofter yesterday wonderfull update on both of our servers!
     
  3. tweakservers

    tweakservers Well-Known Member

    Joined:
    Mar 30, 2006
    Messages:
    379
    Likes Received:
    0
    Trophy Points:
    16
    from which version of mysql you upgraded to?
     
  4. makkintosh

    makkintosh Member

    Joined:
    May 24, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    A week before we had updated mysql from 4.0 to 4.1.19

    but after that we got working subqueries.

    everything was fine

    but yesterday after cPanel has been updated troubles with mysql encoding started.

    first server:
    WHM 10.6.0 cPanel 10.6.0-R55
    FreeBSD 4.10-RELEASE i386 - WHM X v3.1.0

    second:
    WHM 10.8.0 cPanel 10.8.1-R113
    FreeBSD 5.4-RELEASE i386 - WHM X v3.1.0

    we added this line to /etc/my.cnf
    default-character-set=cp1251

    but nothing happened :-(
    only query in the begging of php apps helps to solve the problem
    SET CHARACTER SET cp1251 ...
     
  5. johny_gjx

    johny_gjx Active Member

    Joined:
    Apr 15, 2005
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    I always feel bad about mysql 4.1! I'll watch this topic.
     
  6. caesar1_caesar1

    Joined:
    Oct 5, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Have you restored your DB after upgrading ?
     
  7. makkintosh

    makkintosh Member

    Joined:
    May 24, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    what u mean restored? we didnt touch DB files. they are okay. and it works okay if first write query with charset. but before cPanel update it wasnot necessary.....
     
Loading...

Share This Page