Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysql error : Access denied for user '[cpaneluser]'@'localhost' (using password: NO)

Discussion in 'Database Discussions' started by Terry Bogard, May 8, 2017.

  1. Terry Bogard

    Terry Bogard Registered

    Joined:
    May 8, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cincinnati, OH
    cPanel Access Level:
    Website Owner
    I'm not new to wordpress as I have been in the development industry for last two years. I have been given a site to fix some internal errors which I don’t find possible to resolve on my own.

    The site is hosted on a godaddy shared hosting site. I'm not sure what they did to it but it is unable to connect to its database anymore. I also verified that the (setttings.php) file has the correct credentials but it still unable to connect.

    I'm getting the following errors:

    Notice: Undefined index: host in /home/logomatics/public_html/includes/database.mysql.inc on line 62

    Notice: Undefined index: path in /home/ logomatics/public_html/includes/database.mysql.inc on line 63

    The mysql error was: Access denied for user ' logomatics'@'localhost' (using password: NO).

    What’s really confusing or surprising for me is that the user logomatics is the cpanel system user and not a custom user name that I have configured to access the database.

    Any ideas as to what is behind this error? Godaddy seems to be assuming that everything is running fine and that cpanel has all of the right permissions.

    Thanks!
     
    #1 Terry Bogard, May 8, 2017
    Last edited by a moderator: May 8, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you notice any custom .my.cnf files in the account's home directory (/home/$username/)? If not, could you ask your hosting provider to check and verify if the "sql.safe_mode" option is enabled for the PHP configuration on the system?

    Thank you.
     
Loading...

Share This Page