Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

MySQL error: ERROR 1251: Client does not support authentication protocol requested by

Discussion in 'General Discussion' started by CamronFry, Jan 2, 2005.

  1. CamronFry

    CamronFry BANNED

    Joined:
    Jan 1, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    I am getting this error:
    ERROR 1251: Client does not support authentication protocol requested by server; consider upgrading MySQL client

    It occurs when I hit "Change a User or Database Password"

    How do I correct this?
     
  2. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Nirvana
    Use a MySQL version supported by cPanel. :p
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. noorolhoda

    noorolhoda Active Member

    Joined:
    Jul 19, 2004
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    156
    Hello
    I have the same problem
    just put this in your my.cnf

    [mysqld]
    old-passwords

    :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    Could you please check this link http://dev.mysql.com/doc/mysql/en/old-client.html.
    It solved my problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. rootuser

    rootuser Well-Known Member

    Joined:
    Jan 31, 2005
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    ***INDIA***
    Bijo i have one question, in that site they are saying

    #

    Upgrade all client programs to use a 4.1.1 or newer client library.
    #

    When connecting to the server with a pre-4.1 client program, use an account that still has a pre-4.1-style password.

    but how can i do this?

    How to fix this in mysql related new installations(Like Oscommerce and phpbb)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice