Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

MySQL error in users cPanel

Discussion in 'Database Discussion' started by Stacy HM, Apr 27, 2019.

Tags:
  1. Stacy HM

    Stacy HM Registered

    Joined:
    Apr 27, 2019
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Florida
    cPanel Access Level:
    Root Administrator
    This error is from WHM -> List Accounts -> Account CP link, and also direct cpanel login for accounts:

    The MySQL server is currently offline.
    Mysql::initcache failed: adminbin Cpanel/cpmysql/DBCACHE: exit 11

    Error log snip:

    Code:
    [2019-04-27 21:23:54 -0400] warn [cpanel] Cpanel::Wrap::send_cpwrapd_request adminbin Cpanel/cpmysql/DBCACHE: exit 11: namespace=[Cpanel] module=[cpmysql] function=[DBCACHE]: set error in context mysql: raw_response=[{"statusmsg":"adminbin Cpanel/cpmysql/DBCACHE: exit 11","exit_code":2816,"error":1,"mode":"simple","status":1,"data":"","timeout":0,"version":"2.4","action":"run"}] at /usr/local/cpanel/Cpanel/Wrap.pm line 119, <$socket> line 1.
            Cpanel::Wrap::send_cpwrapd_request("namespace", "Cpanel", "module", "cpmysql", "function", "DBCACHE", "data", "", ...) called at /usr/local/cpanel/Cpanel/AdminBin.pm line 57
            Cpanel::AdminBin::adminrun("cpmysql", "DBCACHE", "") called at /usr/local/cpanel/Cpanel/MysqlFE/DB.pm line 233
            Cpanel::MysqlFE::DB::_initcache("") called at cpanel.pl line 2506
            cpanel::cpanel::domysql("initcache", ARRAY(0x1c12be0)) called at cpanel.pl line 1840
            eval {...} called at cpanel.pl line 1840
            cpanel::cpanel::_api1("Mysql", "mysql", "initcache()", "initcache", ARRAY(0x1c12be0), "safe_html_encode") called at /usr/local/cpanel/Cpanel/Template/Plugin/Api1.pm line 93
            eval {...} called at /usr/local/cpanel/Cpanel/Template/Plugin/Api1.pm line 93
            Cpanel::Template::Plugin::Api1::_api1_exec(0, "Mysql", "initcache", ARRAY(0x1c12be0)) called at /usr/local/cpanel/Cpanel/Template/Plugin/Api1.pm line 47
            Cpanel::Template::Plugin::Api1::_captured_api1_exec("Mysql", "initcache", ARRAY(0x1c12be0)) called at /var/cpanel/template_compiles//usr/local/cpanel/base/frontend/paper_lantern/sql/index.html.tt line 1
            eval {...} called at /var/cpanel/template_compiles//usr/local/cpanel/base/frontend/paper_lantern/sql/index.html.tt line 1
            eval {...} called at /var/cpanel/template_compiles//usr/local/cpanel/base/frontend/paper_lantern/sql/index.html.tt line 1
            Template::Provider::__ANON__(Template::Context=HASH(0x1b85e10)) called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/x86_64-linux-64int/Template/Document.pm line 162
            eval {...} called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/x86_64-linux-64int/Template/Document.pm line 160
            Template::Document::process(Template::Document=HASH(0x1b8a708), Template::Context=HASH(0x1b85e10)) called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/x86_64-linux-64int/Template/Context.pm line 357
            eval {...} called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/x86_64-linux-64int/Template/Context.pm line 327
            Template::Context::process(Template::Context=HASH(0x1b85e10), Template::Document=HASH(0x1b8a708)) called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/x86_64-linux-64int/Template/Service.pm line 94
            eval {...} called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/x86_64-linux-64int/Template/Service.pm line 91
            Template::Service::process(Template::Service=HASH(0x1b859d8), "/usr/local/cpanel/base/frontend/paper_lantern/sql/index.html.tt", HASH(0x1b851c8)) called at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/x86_64-linux-64int/Template.pm line 64
            Template::process(Template=HASH(0x1b85660), "/usr/local/cpanel/base/frontend/paper_lantern/sql/index.html.tt", HASH(0x1b851c8), SCALAR(0x1408d18)) called at /usr/local/cpanel/Cpanel/Template.pm line 477
            Cpanel::Template::process_template("cpanel", HASH(0x1b851c8), HASH(0x1434ab8)) called at cpanel.pl line 1058
            cpanel::cpanel::cptt_exectag("/usr/local/cpanel/base/frontend/paper_lantern/sql/index.html.tt", 1) called at cpanel.pl line 4409
            cpanel::cpanel::run_standard_mode() called at cpanel.pl line 878
            cpanel::cpanel::script("cpanel::cpanel", "./frontend/paper_lantern/sql/index.html.tt") called at cpanel.pl line 321
    I've tried changing the mysql root pass.
    Tried upgrading cpanel.
    Googled until my eyes bled.

    Thoughts?
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,284
    Likes Received:
    2,154
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Stacy HM,

    Were you able to get MySQL running again? If not, can you open a support ticket so we can take a closer look to see what's happening? You can post the ticket number here and we'll update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice