The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysql error

Discussion in 'General Discussion' started by parag joshi, Nov 10, 2009.

  1. parag joshi

    parag joshi Well-Known Member

    Joined:
    Sep 2, 2008
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    My client is getting error while Import at PHPMyAdmin as "#1153 - Got a packet bigger than 'max_allowed_packet' bytes"

    However there is on such option as 'max_allowed_packet' in php.ini or my.cnf on server

    Please advise
     
  2. therootlogin

    therootlogin Registered

    Joined:
    Nov 10, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    /root
    I'll suggest mysql server optimization, you will find lots of threads regarding mysql optimization on this forum or you can google it:)
     
  3. Dicehyden

    Dicehyden Registered

    Joined:
    Nov 10, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    You need to optimize server or here's an other thing you can try. Try editing php and increase limit and see if you get this error.
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Via root SSH access, please use the following command to verify if the setting is already defined:
    Code:
    # grep -i max_allowed_packet /etc/my.cnf
    If the setting is not yet defined (i.e., no output from the above command) then the option could be inserted manually into the MySQL configuration (my.cnf) file using your preferred command-line text editor.

    The following may be used as an example for what to add (under the configuration section labeled "[mysqld]"):
    Code:
    max_allowed_packet = 1M
     
Loading...

Share This Page