The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL fail after update

Discussion in 'General Discussion' started by JBMedeiros, Dec 18, 2007.

  1. JBMedeiros

    JBMedeiros Member

    Joined:
    Sep 2, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys

    A got a new server with CentOS 5.0 and Cpanel.

    ConfigServer Firewall rocomend me to upgrade my system to MySQL 5 and Apache 2.2

    I do it like Tweak Settings Says.

    Selection 5.0 in Tweak Settings, after this a make a Upgrade to Server Software.

    After i haved compiled apache with easyapache with basic options + SuPHP.

    After i executed the /scripts/perlinstaller --force Bundle::DBD::mysql script.

    After that MySQL doesnt work anymore.

    PHPMyAdmin says #2002 - The Server is not responding (or the server socket is not correctly configured)

    I tried /scripts/mysqlup -- force and receive this final lines.

    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists!

    What i forgot or what im making wrong?
     
  2. JBMedeiros

    JBMedeiros Member

    Joined:
    Sep 2, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    I forgot to mention...

    WHM 11.11.0 cPanel 11.16.0-R18450
    CENTOS Enterprise 5 i686 on standard - WHM X v3.1.0
     
  3. JBMedeiros

    JBMedeiros Member

    Joined:
    Sep 2, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
  4. trinity1511

    trinity1511 Member

    Joined:
    Aug 29, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thank you!

    Thank you for writting this post, it saved me a lot of time since I had the same problem :) :D
     
  5. felatio

    felatio Registered

    Joined:
    Oct 12, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks as well , this solved my issue on RedHat 5 with a clean installation
     
  6. aspr

    aspr Member

    Joined:
    Sep 26, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks

    Great Fix!, i was having issue after an upgrade to mysql5.
     
  7. thorlax402

    thorlax402 Member

    Joined:
    Jul 16, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Seems to have worked beautifully. Thanks for the fix!
     
Loading...

Share This Page