The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySql Fails -- once per day. CHANGE Localhost to 127.0.0.1?

Discussion in 'General Discussion' started by sOliver, Aug 5, 2011.

  1. sOliver

    sOliver Active Member

    Joined:
    Oct 25, 2010
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Can anyone take a look at my my.cnf. Is this correct?


    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock



    Any idea what the problem could be?

    QUESTION: How to change "localhost" to 127.0.0.1 as recommended by many people online. Do I have to do that via bind-address?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What happens if you disable leechprotect from your cPanel, assuming you have it enabled by that message.
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If only one site isn't connecting to MySQL, the MySQL password for that database user is likely incorrect or the MySQL user wasn't yet added to the database. I wouldn't go looking to revise the /etc/my.cnf variables for one site not properly connecting to MySQL.

    Also, the leechprotect error message is not related to the WordPress site being unable to connect to its database.
     
Loading...

Share This Page