The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL has failed : a critical problem

Discussion in 'Database Discussions' started by benkhouya, Jun 5, 2011.

Thread Status:
Not open for further replies.
  1. benkhouya

    benkhouya Registered

    Joined:
    Jun 5, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I have a serious problem: MySQL doesn't start with fresh install of cPanel !

    Main >> Restart Services >> SQL Server (MySQL) >> Restarting MySQL Server
    Code:
    Waiting for mysql to restart...............finished.
    
    mysqld_safe (/bin/sh /usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-file=/var/lib/mysql/vps.domain.tld.pid) running as root with PID 7804
    mysqld (/usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --log-error=/var/lib/mysql/vps.domain.tld.err --pid-file=/var/lib/mysql/vps.domain.tld.pid) running as mysql with PID 7870
    
    mysql has failed, please contact the sysadmin (result was "mysql is not running").
    thanks in advance.
    Client ID: 479
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Was a ticket opened about this issue? We do have an internal case opened (50412) about MySQL on new installations prior to 11.30.0.27 having had this issue where a blank password is set for root MySQL and causing some issues with MySQL properly installing. Additionally, if the machine isn't licensed for cPanel prior to installing cPanel, this issue and several others will crop up.
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Case 50412 was resolved in version 11.30.0.27. To see if this version has reached your update tier, visit Downloads - cPanel Inc.
     
  4. IPSecureNetwork

    IPSecureNetwork Well-Known Member

    Joined:
    May 28, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    im having the same problem .. mysql dont install on fresh installation.
    11.30.1 its the version of WHM

    i found this when the mysql51-server fails..

    Cany anyone help me?.. if someone fix this. please tell me how.

    Thanks..

    Code:
     mysql_client_test.o -pthread -pthread  ../libmysqld.a -lcrypt -lm -lwrap -lcrypt -lm -lz -pthread
    Making all in support-files
    cd: can't cd to support-files
    *** Error code 1
    1 error
    *** Error code 1
    
    Stop in /usr/ports/databases/mysql51-server.
    ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20110728-57005-ez1bqk-0 env make FETCH_BEFORE_ARGS=-q
    ** Fix the problem and try again.
    --->  Build of databases/mysql51-server ended at: Thu, 28 Jul 2011 11:51:58 -0500 (consumed 00:12:26)
    --->  Fresh installation of databases/mysql51-server ended at: Thu, 28 Jul 2011 11:51:58 -0500 (consumed 00:12:28)
    --->  ** Install tasks 1: 0 done, 0 ignored, 0 skipped and 1 failed
    --->  Listing the results (+:done / -:ignored / *:skipped / !:failed)
            ! databases/mysql51-server      (new compiler error)
    --->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
    --->  Session ended at: Thu, 28 Jul 2011 11:51:58 -0500 (consumed 00:12:29)
    Running post install scripts for mysql-server....Done
    
     
  5. IPSecureNetwork

    IPSecureNetwork Well-Known Member

    Joined:
    May 28, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    the OS is FreeBSD 7.4 -p2 32 bits.
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Known issues were resolved, so since this is a yet unknown issue, please submit a bug report about this by clicking the Bugs link at the top of the page or submitting a support ticket. If you experience difficulty with this, just email me at sales@cpanel.net and I'll route your email into our bug reporting system.

    Anyone else experiencing this issue should do the same, the more reports we get, the faster this will get fixed and the more information we have for properly resolving this issue. I am closing this thread now since the fix for the previously known issue has propagated to all update tiers.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page