The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL - high memory usage

Discussion in 'General Discussion' started by shizzle, Apr 18, 2005.

  1. shizzle

    shizzle Member

    Joined:
    Sep 26, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    hi,
    i have the followning problem:

    if i chceck Main >> Server Status >> CPU/Memory/MySQL Usage i get a 113% usage of the memory on this process:

    mysql 3.72 113.07 0.0
    Top Process %CPU 6.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/srv1.compacthost.com.pid --skip-locking --port3306 --socket/var/lib/mysql/mysql.sock
    Top Process %CPU 4.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/srv1.compacthost.com.pid --skip-locking --port3306 --socket/var/lib/mysql/mysql.sock
    Top Process %CPU 2.2 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/srv1.compacthost.com.pid --skip-locking --port3306 --socket/var/lib/mysql/mysql.sock

    the CPU usage is normal, it has to do something with sessions, if i delete the session data in the tmp folder, the memory usage goes down... someone told me that this helps.. yep it helps but in 3-4 days is the mem usage again high.. perhaps is the MySQL configuration wrong?!

    can somebody help me?

    thanks
     
  2. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Oh i checked mine and found it to be that high almost in all daily reports. This spiking has started from 5th March 2006 and nothing much has been done on server except for running ./upcp

    Not really sure if anything has changed after 5th March 2005 from cPanel's end. I am on CURRENT Tree

    Anybody else seeing this??

    TIA
    Anup
     
  3. linuxserverguy

    linuxserverguy Active Member

    Joined:
    Apr 14, 2005
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    yes most of my servers with current cpanel builds are showing HIGH mysql ram usage too. this is really bugging me ... cpanel pro's can you answer is this bug or some nuts and bolts need to tighten?
     
  4. Daniel Artes

    Daniel Artes Well-Known Member

    Joined:
    Jun 21, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA - Baltimore
    same problem over here..
     
  5. t9clkclnr

    t9clkclnr Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Southern California
    yes i'm experiencing that daily as well

    yes i experience it on my 2 servers as well.
     
  6. t9clkclnr

    t9clkclnr Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Southern California
    bump

    any response to this. have done some searches with no positive result.
     
  7. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Had the same problem on a Server also using Current and switching to Release solved the problem.
     
  8. t9clkclnr

    t9clkclnr Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Southern California
    already in release update mode and no luck

    my server is set to release and from the last 2 updates I've run over the past month it's been the same problem.
     
  9. MK Hosting

    MK Hosting Active Member

    Joined:
    Dec 5, 2005
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK, Milton Keynes
    Any updates on this? I am having the same problem.
     
  10. kship

    kship Member

    Joined:
    Oct 29, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    HUNTSVILLE, TEXAS
    same

    same here as well
     
  11. kship

    kship Member

    Joined:
    Oct 29, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    HUNTSVILLE, TEXAS
    possible fix

    remove the advanced guestbook from the server completely and remove any instances of it installed. I did this and the server has been purring nicely since.
     
Loading...

Share This Page