Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

MySQL is Dead - In Desperate need of help

Discussion in 'Database Discussion' started by Mindlash, Sep 6, 2014.

  1. Mindlash

    Mindlash Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    156
    Quick backstory:

    I've been trying to upgrade/optimize server, using anything from PHP-FPM and MPM Event with xcache, even as far as nginx/Engintron ... never had any real luck with any of them...

    After uninstalling (pick any of the above mods), I've been left with a dead MySQL server. I can not start it, debug it, upgrade it, anything.

    EasyApache is stuck @:
    Code:
    !! sub-step '1' !!
    !! sub-step '2' !!
    Cpanel::DBI::Mysql connect('','root',...) failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) at /usr/local/cpanel/Cpanel/MysqlUtils/Connect.pm line 136
    
    I ran EasyApache after instructed to do so after my latest WHM MySQL Upgrade (5.5 was not available, only 5.6, which I did). This supposedly worked and instructed me to now recompile apache/php... which I tried.



    I've tried this suggestion
    Code:
    /scripts/update_local_rpm_versions --edit target_settings.MySQL55 uninstalled
    /scripts/check_cpanel_rpms --fix
    /scripts/update_local_rpm_versions --edit target_settings.MySQL55 installed
    /scripts/check_cpanel_rpms --fix
    This, and any future #service mysql start result in the following (via error log)
    Code:
    140906 14:42:05 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    140906 14:42:05 [Note] Plugin 'FEDERATED' is disabled.
    140906 14:42:05 InnoDB: The InnoDB memory heap is disabled
    140906 14:42:05 InnoDB: Mutexes and rw_locks use InnoDB's own implementation
    140906 14:42:05 InnoDB: Compressed tables use zlib 1.2.3
    140906 14:42:05 InnoDB: Using Linux native AIO
    140906 14:42:05 InnoDB: Initializing buffer pool, size = 128.0M
    140906 14:42:05 InnoDB: Completed initialization of buffer pool
    InnoDB: Error: log file ./ib_logfile0 is of different size 0 67108864 bytes
    InnoDB: than specified in the .cnf file 0 5242880 bytes!
    140906 14:42:05 [ERROR] Plugin 'InnoDB' init function returned error.
    140906 14:42:05 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    140906 14:42:05 [ERROR] Unknown/unsupported storage engine: InnoDB
    140906 14:42:05 [ERROR] Aborting
    
    140906 14:42:05 [Note] /usr/sbin/mysqld: Shutdown complete
    
    140906 14:42:05 mysqld_safe mysqld from pid file /var/lib/mysql/mydomain.com.pid ended
    I'm totally stuck. I can't seem to upgrade/side-grade/downgrade/any-grade to get this server running.

    PLEASE HELP.

    Regards,

    Sleepless
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Mindlash

    Mindlash Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    156
    Never fails, I post for help, after hours (days actually) of issues... then minutes afterwards, find *my* answer.

    Code:
    rm /var/lib/mysql/ib_logfile0
    rm /var/lib/mysql/ib_logfile1
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    751
    Likes Received:
    11
    Trophy Points:
    143
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Howdy,

    I was reading your post and I was thinking you should move those files out of the way. I'm glad it worked out :)

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice