The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL Major Problem!

Discussion in 'General Discussion' started by Mysteerie, Dec 17, 2004.

  1. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    My websites are slowing down, and I think it's mysql, since on pages where it doesn't connect to a mysql db, my pages load fast. My MySQL Process List shows this:

    Code:
    +------+---------------+-----------+-----------------+---------+------+----------------+------------------------------------------------------------------------------+
    | Id   | User          | Host      | db              | Command | Time | State          | Info                                                                         |
    +------+---------------+-----------+-----------------+---------+------+----------------+------------------------------------------------------------------------------+
    | 981  | gamefaq2      | localhost | gamefaq2_boards | Query   | 0    | Sorting result | SELECT time FROM messages WHERE board='5552' ORDER BY messageid DESC LIMIT 1 |
    | 995  | gamefaq2      | localhost | gamefaq2_boards | Sleep   | 25   |                |                                                                              |
    | 997  | gamefaq2      | localhost | gamefaq2_boards | Sleep   | 23   |                |                                                                              |
    | 1005 | bihira        | localhost | bihira_forums   | Sleep   | 16   |                |                                                                              |
    | 1009 | gamefaq2      | localhost | gamefaq2_boards | Sleep   | 13   |                |                                                                              |
    | 1013 | gamefaqs      | localhost | gamefaqs_SQL    | Sleep   | 2    |                |                                                                              |
    | 1017 | gamefaq1      | localhost | gamefaq1_boards | Sleep   | 0    |                |                                                                              |
    | 1018 | divineth_root | localhost | divineth_boards | Sleep   | 0    |                |                                                                              |
    | 1019 | root          | localhost |                 | Query   | 0    |                | show processlist                                                             |
    +------+---------------+-----------+-----------------+---------+------+----------------+------------------------------------------------------------------------------+
    I have put a timelimit to shut down the process after 30 seconds. I also turned off persistant connections, does anyone have a soulutions and can help me! I have posted this problem before but no one was able to find a solution.
     
  2. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Persistent connections can actually increase MySQL performance in certain situations.

    Try going through the larger, and more heavily used databases and Optimize them.
     
  3. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    I turned persistant back on and repaired the larger db and anyone listed that had the recurring sleep problem. Though the problem still remains.
     
  4. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Don't just repair, do the Optimize as well. Optimizing tables defragments them, thus helping to increase performance, if that is the problem.
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Add indicies to your tables as well.
     
  6. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    I fixed it for him. It was a MySQL misconfiguration.
     
Loading...

Share This Page