Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

mySQL not working on FreeBSD

Discussion in 'General Discussion' started by kofi, Oct 12, 2004.

  1. kofi

    kofi Well-Known Member

    Feb 3, 2004
    Likes Received:
    Trophy Points:
    We have several Linux flavours with cpanel on different servers, but we just had a FreeBSD one setup, and we cannot seem to get mySQL working.

    mySQL is running, and we are able to login via console using root, and via phpmyadmin in WHM, but when we login to cPanel accounts and try to create a mySQL db, it states the db has been made, but it actually does not. Usernames can be created without a problem. An observation we made was made that when looking at phpmyadmin through cPanel was that it had No Permission under the Create Database field.

    What we tried::
    1. Restart mysql via command line and via cpanel
    2. Reset mysql root password to several different passwords
    3. Create a database through phpmyadmin (using whm as root) - this worked

    What we think might be the problem:
    cPanel is not interfacing with mysql correctly and hence is not allowing users to create their own dbs, looks like a permissions problem.

    Anyone had a similar problem?
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. sjackson909

    sjackson909 Well-Known Member

    Jun 8, 2004
    Likes Received:
    Trophy Points:
    Columbus, OH
    Make sure your perms are set right on your mysql data dir. I'm bet this is your issue.

    chown -R mysql:mysql /var/db/mysql/


Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice