The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysql on DNSONLY box

Discussion in 'Data Protection' started by niak, Jul 28, 2006.

  1. niak

    niak Registered

    Joined:
    Dec 21, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    i have been trying to install postfixadmin to administer backup mx domains on my dnsonly box. the server is working fine as part of the dns cluster. Im struggling getting mysql to run on the server. i can run /scripts/mysqlup fine, but when i try and connect from the client i get:

    Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    does cpanel dnsonly somehow disable the mysql server?

    im running CentOS 4.3
     
  2. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    In SSH run

    Code:
    ls /etc/*dis*
    
    I just deleted the disabled files in /etc to get mysql working, we are running a DNS only, with MySql, Httpd, Postfix and Mailscanner w/spamassassin.

    Good Luck.
     
  3. niak

    niak Registered

    Joined:
    Dec 21, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    i did delete the apachedisable and mysqldisable files and this did get apache working correctly. however, i still cannot get mysql running on this box with the same mysql.sock error as posted above.

    any ideas ?
     
  4. niak

    niak Registered

    Joined:
    Dec 21, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    nevermind, i did get it going.

    i was getting this in the /var/log/mysql.log

    060808 12:19:30 mysqld started
    060808 12:19:30 /usr/sbin/mysqld: unknown variable 'old_passwords=1'

    removed the old_passwords=1 from the my.conf and ran a

    /usr/bin/mysql_install_db --user=mysql
     
Loading...

Share This Page