The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysql overload the cpu

Discussion in 'Workarounds and Optimization' started by Dante78, Jul 28, 2011.

  1. Dante78

    Dante78 Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Hello

    Since last Friday my server have 111% CPU overload on mysql processes. I saw that on Main - System health - Process Manager. I have restarted the mysql server still nothing. Then I run the command mysqladmin processlist. Nothing strange....

    What could it be? How can I trace the account who's doing this?


    On daily process log I have the mysql user in top of the resources consumption followed far by regular users but no one with more then 5% consumption
    Thanks
     
  2. Dante78

    Dante78 Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
  3. Dante78

    Dante78 Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Daily i get this message from server


    While processing, the cpu has been
    maxed out for more than a 6 hour period. *The current load/uptime line on the server at the time of
    this email is
    *13:28:58 up 12 days, 27 min, *0 users, *load average: 5.13, 4.13, 4.98
    *You should check the server to see why the load is so high and take
    steps to lower the load. *If you want stats to continue to run even with a high load; Edit
    /var/cpanel/cpanel.config and change extracpus to a number larger then 0 (run
    /usr/local/cpanel/startup afterwards to pickup the changes).


    Editing cPanel.config will show me who's loading the mysql server?
     
  4. Dante78

    Dante78 Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    And I get this all the time in mysql process list


    6696 eximstats localhost eximstats Sleep 26 NULL
     
  5. ramindia

    ramindia Well-Known Member

    Joined:
    Apr 3, 2011
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    just download mysqltuner and run the paste here for recommendation
    and also post your existing my.conf to suggest.


    mysqladmin proc will show the process list.

    Ram
     
  6. syslint

    syslint Well-Known Member

    Joined:
    Oct 9, 2006
    Messages:
    249
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Please check for any spaming issues too . Also enable RBL s from whm -> Exim configuration editor
     
  7. Dante78

    Dante78 Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    I found with mytop two accounts that were responsabile for this mess. Thanks all for support

    thanks alot
     
  8. wrender

    wrender Well-Known Member

    Joined:
    Sep 29, 2007
    Messages:
    69
    Likes Received:
    3
    Trophy Points:
    8
    I was having a lot of MySQL performance issues for a while too. I found upgrading to MySQL 5.1 really improved things. And as well running the mysqltunner script. After that I was still having the occasional client that was doing bad things and overloading the server. I installed Cloud Linux (You can seamlessly upgrade to Cloud Linux as it basically converts the OS as it is running). This immediately put proper CPU limits on accounts in place and now things are running much faster.

    Regards,


    Wes


    www.otherdata.com
     
Loading...

Share This Page