The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL problem after build 51 update... help!!!

Discussion in 'General Discussion' started by cass, Aug 7, 2002.

  1. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
    On every CPANEL main window I get:
    on the &Mysql Databases&
    ERROR 1045: Access denied for user: 'root@localhost' (Using password: NO) 0

    also on advanced / mysql and with phpmyadmin...
    what's up?
    I just updated from build 42 to 51.
    what can I do?

    Regards.
     
  2. parag

    parag Well-Known Member

    Joined:
    Aug 16, 2001
    Messages:
    115
    Likes Received:
    0
    Trophy Points:
    16
    [quote:3bc112e197][i:3bc112e197]Originally posted by cass[/i:3bc112e197]

    On every CPANEL main window I get:
    on the &Mysql Databases&
    ERROR 1045: Access denied for user: 'root@localhost' (Using password: NO) 0

    also on advanced / mysql and with phpmyadmin...
    what's up?
    I just updated from build 42 to 51.
    what can I do?

    Regards.[/quote:3bc112e197]

    Hi Cass

    go to WHM and scroll down to MYSQL menu

    click on Reset Mysql Root Password - set the new password

    thats it and u will be ok with the root access to mysql
    best regards
    Parag
     
  3. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
    I've already changed the pass ... with this and manually too...
    but nothing ...
    I can access Mysql without problems manually...

    BUT... not from phpmyadmin or cpanel...
    I get this on phpmyadmin:
    Wrong username/password. Access denied.

    I get this on cpanel homepage (where the sql db number goes):
    ERROR 1045: Access denied for user: 'root@localhost' (Using password: NO) 0

    some other thing is that all my users home is set to
    /home/username/mail/username now ... when it was /home/username

    I think this is for the imap ? ... dunno...
    BUT... when I ADD a subdomain for example ... the apache config is WRONG cause it sets to :
    /home/username/mail/username/public_html/subdomain

    so.. I think they make big mistakes on build 51 ... and I make a big mistake updating to it ... hehe.

    waiting for the new BUG FREE version ... PLEASE!! :)

    Regards.
     
  4. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
    Damn... I get what it this ...
    when I installed build 51 ... ALL MY /etc/passwd fucked up... it adds /mail/username to all... then to root too...
    so maybe the scripts was trying to read
    /root/mail/root/.my.cnf

    Anyway... I replaced existing /etc/passwd with the one named /etc/passwd.precpanel that was just pre-last update... and all goes normal :)

    bad bad ....
    It was something in the update sure, maybe this is needed by imap? dunno really.

    anyway... is this is the case... I hope to see the &option& for imap, not the forced one... can I opt out? lol

    regards.
     
  5. bdraco

    bdraco Guest

    http://web.cpanel.net/bugzilla/show_bug.cgi?id=758
    -
    Check for someone's homedir being linked to /. I'll update the script to resolve symlinks, but if this is the case other bad things will happen in the future anyways so fixing the problem now would be a good idea (tm).
     
  6. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
    My /etc/passwd was like this after the update... do you know why?
    root:x:0:0:root:/root/mail/root:/bin/bash
    bin:x:1:1:bin:/bin/mail/bin:/sbin/nologin
    daemon:x:2:2:daemon:/sbin/mail/daemon:/sbin/nologin
    adm:x:3:4:adm:/var/adm/mail/adm:/sbin/nologin
    lp:x:4:7:lp:/var/spool/lpd/mail/lp:/sbin/nologin
    sync:x:5:0:sync:/sbin/mail/sync:/bin/sync
    shutdown:x:6:0:shutdown:/sbin/mail/shutdown:/sbin/shutdown
    halt:x:7:0:halt:/sbin/mail/halt:/sbin/halt
    mail:x:8:12:mail:/var/spool/mail/mail/mail:/sbin/nologin
    news:x:9:13:news:/var/spool/news/mail/news:
    uucp:x:10:14:uucp:/var/spool/uucp/mail/uucp:/sbin/nologin
    operator:x:11:0:eek:perator:/root/mail/operator:/sbin/nologin
    games:x:12:100:games:/usr/games/mail/games:/sbin/nologin
    gopher:x:13:30:gopher:/var/gopher/mail/gopher:/sbin/nologin
    ftp:x:14:50:FTP User:/var/ftp/mail/ftp:/sbin/nologin
    nobody:x:99:99:Nobody://mail/nobody:/sbin/nologin
    vcsa:x:69:69:virtual console memory owner:/dev/mail/vcsa:/sbin/nologin
    mailnull:x:47:47::/var/spool/mqueue/mail/mailnull:/dev/null
    rpm:x:37:37::/var/lib/rpm/mail/rpm:/bin/bash
    ...etc

    so the &/mail/username& was added to all users...
    I just deleted ALL the /mail/username to get
    root:x:0:0:root:/root:/bin/bash
    bin:x:1:1:bin:/bin:/sbin/nologin
    ...etc.

    is this right? ... or I need to use that /mail/user thing in the home?
    I'm still asking ... was the script wich do this change right? :)

    Regards.

    [EDIT]
    oh, if this symlinks things is a possible security problem or somehing ... better leave it as is :) ... to not resolve symlinks I mean. Regards.
    [/EDIT]
     
Loading...

Share This Page