The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL problem after kernel upgrade

Discussion in 'General Discussion' started by platypus, Apr 25, 2006.

  1. platypus

    platypus Member

    Jun 5, 2004
    Likes Received:
    Trophy Points:
    Errors after kernel upgrade

    I haven't found any reference to this problem elsewhere, so I think cPanel might be related to the issue.

    I run a Redhat (RHEL3) server on a dual xeon processor with the latest cPanel. Linux kernel is 2.4.21-20.0.1.ELsmp. I upgraded the kernel to fix a known iowait issue, using "up2date -uf kernel-smp". After a reboot, the new kernel is running, but MySQL won't run, complaining of a problem using/finding the mysql.sock file. I worked on that issue for an hour, even manually using touch, chmod and chown on the mysql.sock file in the correct directory to re-create the sock file, and then restarting MySQL via WHM. MySQL still won't work. Also related, is that after I install the new kernel, WHM starts complaining about an invalid license file or something, and provides a countdown until it re-attempts verification... once the countdown finishes, it "seems" to work ok. But MySQL won't go. When I revert to the older kernel and restart, everything works fine.

    Please help! I also heard there is a cPanel script for "fixing" certain MySQL issues. What do I do to fix this? THANKS!
    #1 platypus, Apr 25, 2006
    Last edited: Apr 25, 2006

Share This Page