The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mysql problem again

Discussion in 'General Discussion' started by Secret Agent, Nov 21, 2004.

  1. Secret Agent

    Secret Agent Guest

    MySQL, Exim and PostgreSQL shown down (red) in WHM after doing a simple Apache update and cPanel update (Release).

    Restarted MySQL

    DBI connect('mysql:localhost','root',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /scripts/restartsrv_mysql line 75 mysql has failed, please contact the sysadmin (result was "Warning, no valid mysql.sock file found.mysql has failed").


    I ran /scripts/upcp --force
    ./updatenow
    ./fixeverything

    Still doesn't fix it.

    Please give me a hand.

    Specs:
    Fedora Core 1
    cPanel 9.9.8 R119
     
  2. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    ls -al /tmp | grep sock

    paste results here.
     
  3. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Same issue here:


    root@zeus [/]# ls -al /tmp | grep sock
    root@zeus [/]#
     
  4. Secret Agent

    Secret Agent Guest

    I ran that and got nothing, just a return (no results).
     
  5. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Just in case you need professional help to get MySQL, Php and other service up and and running, Sned us an email note: andyreed@servertune.com
     
  6. Secret Agent

    Secret Agent Guest

    I appreciate that but I doubt this is the right place to advertise (not to be rude). Someone might bash you for that eventually lol :)
     
  7. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Easy fix:

    Make sure in my.cnf, that you have the the following in there:
    socket=/var/tmp/mysql.sock

    Once thats edited ans saved, do the following to symlink the socket:

    ln -s /var/lib/mysql/mysql.sock /var/tmp/mysql.sock
     
  8. Secret Agent

    Secret Agent Guest

    Anyone please?
     
  9. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Little out of my area here but you might try creating the symlink this way instead:
    ln -s /var/lib/mysql/mysql.sock /tmp/mysql.sock
    Would also comment out the my.cnf socket entry to test and restart MySQL. Then add symlink.
     
  10. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    I spent hours try this and everything else on the forums and nothing worked. What I did was change the SQL version in WHM to version 3, do a force update so it downgraded MySQL to version 3.x then I changed it back to version 4 and did the same thing.

    Fixed it for me.
     
  11. ttiger

    ttiger Member

    Joined:
    Sep 1, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I tried that twice didn't work.
     
  12. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Are you able to connect using a remote connection? Is just the mysql.sock not working or is MySQL itself not working?
     
  13. Secret Agent

    Secret Agent Guest

    mysql is just not working
     
  14. moricio

    moricio Member

    Joined:
    Apr 30, 2004
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Colombia
    my.cnf, that is my problem

    I was making tests to replicate data from my server to another one and I modified this file for this to work.

    I forgot and left all the stuff there.

    Well, next time I did a reboot MYSQL didn't started.

    /etc/my.cnf must have only two lines to really work as follows:

    set-variable = max_connections=500
    safe-show-database

    Then restart your server and then erase and redo the symlink as follows

    rm /var/tmp/mysql.sock
    ln -s /var/lib/mysql/mysql.sock /var/tmp/mysql.sock

    Check back and go on!

    Good luck!

    Mauricio Ramirez
     
    #15 moricio, Nov 24, 2004
    Last edited: Nov 24, 2004
  15. jezzzicuh

    jezzzicuh Registered

    Joined:
    Sep 11, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Me too

    I am having the same problems as everyone else, and I have tried just about everything mentioned. If this is a WHM/cpanel problem, it is EXTREMELY AGGRAVATING. Has anyone had any luck with a solution?? Thanks.
     
  16. Secret Agent

    Secret Agent Guest

    Any cpanel tech want to give us a hand here? We'll be "thankful" on this holiday for that :D
     
  17. Secret Agent

    Secret Agent Guest

    Updated apache again (not v2 for the record)....checked mysql module (as is by default) and not system mysql module (by default unchecked also)

    Some "failed" results during update...

    Are you sure you wish to proceed? Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    Stopping postgresql service: [FAILED]
    Starting postgresql service: [FAILED]
    You should now configure postgresql from WHM!
    You should now configure postgresql from WHM!
    You should now configure postgresql from WHM!
    You should now configure postgresql from WHM!


    Server status still shows exim, postgresql and mysql failed :(
     
  18. Secret Agent

    Secret Agent Guest

    This is ridiculous. So many people are having this same problem suddenly and no response or help from cpanel yet.
     
  19. Secret Agent

    Secret Agent Guest

    I clicked on install an rpm in whm and it is completely empty, even after rebuilding rpm database!
     
Loading...

Share This Page