The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysql problem

Discussion in 'General Discussion' started by shann, May 9, 2004.

  1. shann

    shann Well-Known Member

    Joined:
    Jul 5, 2002
    Messages:
    366
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Website Owner
    Hi,

    Everytime I reboot our server, we need to resart mysql manuall in order to work. Do you guys any the causes.

    I have find this info in log file.

    030619 14:27:09 Can't start server: Bind on TCP/IP port: Address already in use
    030619 14:27:09 Do you already have another mysqld server running on port: 3306
    ?

    Do you guys know the problem?.

    Thanks
    Shan
     
  2. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Sounds like it is shutting down hard and not clearing the pid file. Might want to check your configurations and make sure the mysql.sock is setup correctly and the pid files are being created and deleted with ons/offs.
     
  3. shann

    shann Well-Known Member

    Joined:
    Jul 5, 2002
    Messages:
    366
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Website Owner
    Thank You for your info.

    I have jsut noticed that from /tmp/mysql to /var/lib/mysql, there is no link.

    would this cause the problem.

    thanks
     
  4. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    you may need to create a symbolic link to the socket file.

    Mickalo
     
Loading...

Share This Page