The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL problem

Discussion in 'General Discussion' started by Secret Agent, Jun 30, 2005.

  1. Secret Agent

    Secret Agent Guest

    Mysql giving the usual error


    I cannot access phpmyadmin naturally, changed root password and got this error:

    Mysql password change failed!!
    A forced reset will now be attempted

    Got a failure from command:
    /usr/bin/mysql --no-defaults --force --user=root --host=localhost --password=v --database=mysql
    Please check the above output and try again.


    I chmod 1777 /tmp

    I changed local password fo rmysql

    I removed " from username/password from /root/.my.cnf also and restarted mysql,
    got this error:


    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Access denied for user 'root'@'localhost' (using password: YES)' mysql has failed, please contact the sysadmin (result was "mysql has failed").


    I did /scripts/updatenow and /scripts/upcp --force (CURRENT)

    mysql.sock is already in /tmp and /var/lib/mysql as well

    I did not bother with /scripts/mysqlup --force because the few times I've ran that in the past it wiped out databases

    Nothing works.

    Please help
     
  2. Secret Agent

    Secret Agent Guest

    Fixed

    /scripts/securetmp

    I had that done, but had to undo / redo for whatever reason
     
  3. Secret Agent

    Secret Agent Guest

    Ridiculous!

    Its not working again!

    I didn't touch anything after I ran the above and now its broken
     
  4. Secret Agent

    Secret Agent Guest

    I restart mysql in ssh, it works fine and able to login to phpmyadmin

    I restart in whm, it screws up everything

    root@server [/scripts]# service mysql stop
    No mysqld pid file found. Looked for /var/lib/mysql/server.domain.com.pid.
     
    #4 Secret Agent, Jun 30, 2005
    Last edited by a moderator: Jun 30, 2005
  5. Secret Agent

    Secret Agent Guest

    Ok...

    WHILE mysql restarts in WHM, I can squeeze into phpmyadmin, when it finishes restarting and gives the error, I get access denied in phpmyadmin
     
  6. eos1

    eos1 Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    phpMyAdmin from WHM and cPanel ---> just a blank page !?

    FreeBSD
    10.4.0-EDGE_47
     
  7. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    check the error logs - sounds like mysql is failing after the service starts. You may be able to find the reason in the logs. Or at least a point to the right direction
     
  8. Jeffa

    Jeffa Member

    Joined:
    Jun 19, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    MySQL Error.

    You will probably find when you try to run mysql you also get
    error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists!

    I've tried everything, inculding ln -s, permissions etc, removing all mysql products and reinstalling.. Nothing works.. Mysql looks very much like it hangs too...

    -Jeffa
     
Loading...

Share This Page