The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL problem

Discussion in 'General Discussion' started by thewird, Mar 29, 2006.

  1. thewird

    thewird Well-Known Member

    Joined:
    Jan 4, 2006
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto
    A fresh install with CentOS 4.3 and Cpanel 10.8.1-R113 and MySQL doesn't work. Please help. Thanks

    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)' Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists! mysql has failed, please contact the sysadmin (result was "Warning, no valid mysql.sock file found.mysql has failed").
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Try

    /scripts/mysqlup --force
     
  3. thewird

    thewird Well-Known Member

    Joined:
    Jan 4, 2006
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto
    When I did that, it created a bunch of errors towards the end (im assuming this was a reinstall)

     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Check on /tmp directory and see if chmod is set to 1777. Run this command at the prompt: /scripts/restartsrv mysql
    If that doesn't work, login to WHM >> SQL Services >> MySQL Root Password and enter a new password. See if that helps!
     
  5. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
  6. James222

    James222 Registered

    Joined:
    Apr 1, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    MySQL Centos 4.3 problems

    Hi

    Faced the same problem and here is the solution worked for me.

    In install log file during installation of mysql 4.0 (Cpanel uninstall the cento 4.3's mysql 4.1 and install 4.0) the error was "unknown variable 'old_passwords=1' " .

    When cpanel uninstall the mysql 4.1 it do not delete the /etc/my.cnf file which have this line in it.
    variable 'old_passwords=1'

    Just removed /etc/my.cnf manually prior to start installation of cpanel. And everything worked ok.

    comments/suggestions are welcome.

    Regards

    James

    http://www.aplushosting.com
     
    #6 James222, Apr 4, 2006
    Last edited: Apr 4, 2006
Loading...

Share This Page