The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL Problems

Discussion in 'General Discussion' started by computerbiz, Dec 19, 2005.

  1. computerbiz

    computerbiz Registered

    Joined:
    Dec 19, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Helo All,

    I am a newbie and I have run into a problem.

    I have intalled OS Commrce on one of my domains and when I try to access it, I get the following error:

    FATAL ERROR: register_globals is disabled in php.ini, please enable it!


    Where and/or how do I enable it?

    Also, when I click on MySQL Admin I get a blank Page.

    Please help.

    Thanks
     
  2. ManojB

    ManojB Well-Known Member

    Joined:
    Mar 25, 2005
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    pune
    You have to enable the register_globals in your php.ini file. Edit the file php.ini "/usr/lib/php.ini" and set "register_globals = On"

    Else

    You can create a .htaccess and add the following line to this file

    php_flag register_globals on
     
  3. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    adding the line in your .htaccess is a better idea where as having register_globals On in your php.ini is not secure.
     
  4. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth
    You cannot alter the php.ini settings with .htaccess when running PHP as cgi/phpsuexec.

    Check this link,

    http://webhostingtalk.com/showthread.php?t=421482
     
Loading...

Share This Page