The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL Tables crashed

Discussion in 'Database Discussions' started by Shalabh, Jul 30, 2013.

  1. Shalabh

    Shalabh Registered

    Joined:
    Jul 30, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi,

    I am facing an issue with my website which is running on a VPS. Yesterday, Some of the MySQL tables crashed and I got it repaired from my web hosting company. They also changed some of the parameters in my.cnf files. Since then, one of the conditions set in my coding for "adding language pairs" in user's profile has stopped working.

    My website is an online marketplace for translators and translation clients. A free member can enter up to 2 language pairs(first table which got crashed) in his profile where as paid member can enter up to 18 language pairs. But, after my web hosting company resolved the issue of crashed tables in my database. This condition has stopped working i.e. whether a user is a free member or a paid member they are now able to enter "n" number of language pairs to their profile. However, a free member should only be allowed to enter 2 language pairs and paid member cannot enter more than 18 language pairs. However, when I run the same script on local server the condition works fine. How can I fix this issue and prevent it in future?

    Q How language pair is added to user's profile?
    A There is a "+" button available on user's profile page- by clicking + button a pop window with two drop downs open up, one drop down is for selecting "source language" and second drop down is for selecting "target language". After the user has selected languages in both drop down he clicks on submit button and the pop up window and main webpage(where language pair is displayed) are refreshed, and then the language pairs are displayed on user's profile and stored in the database.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,711
    Likes Received:
    658
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's possible the changes your hosting provider made to the /etc/my.cnf file are preventing your script from working in the same manner it has in the past. Have you tried installing a separate version of this application in a subdirectory to see if the issue persists on a test installation? Also, do you get any specific error messages when using this option of your script?

    Thank you.
     
Loading...

Share This Page