MySql TLS version wannings

Operating System & Version
centos version 7
cPanel & WHM Version
11.106.0.11

Anupkum

Member
Dec 14, 2020
11
0
1
India
cPanel Access Level
Root Administrator
Hello,

MySql server is showing following wannings.

A deprecated TLS version TLSv1 is enabled. Please use TLSv1.2 or higher.
CA certificate ca.pem is self signed.


I checked for updates and it is stating mysqld 5.7.40 and saying all packages are updated.

Please help me fix this issue...
 

cPanelWilliam

Administrator
Staff member
Mar 13, 2018
161
23
93
Houston
cPanel Access Level
Root Administrator
Hi! When you run the following command as root, does MySQL show that support for TLSv1 is enabled?

mysql -e "SHOW GLOBAL VARIABLES LIKE 'tls_version';"

If so, you can force MySQL to use only TLS 1.2 and 1.3 by adding the following to the end of /etc/my.cnf, then restarting the service:

Code:
[mysqld]

tls_version=TLSv1.2,TLSv1.3
 

Anupkum

Member
Dec 14, 2020
11
0
1
India
cPanel Access Level
Root Administrator
Hi William,
thanks for your reply. It worked for me to fix TLS version issue.

However CA certificate ca.pem is self signed error is still there.

Kindly help me fix this.
 

cPanelWilliam

Administrator
Staff member
Mar 13, 2018
161
23
93
Houston
cPanel Access Level
Root Administrator