The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysql Upgrade Error

Discussion in 'General Discussion' started by adapter, Jul 26, 2004.

  1. adapter

    adapter Well-Known Member
    PartnerNOC

    Joined:
    Sep 17, 2003
    Messages:
    391
    Likes Received:
    0
    Trophy Points:
    16
    If i try to upgrade Mysql with /scripts/sysup i get the following error:


    chkservd is up to date (Sun Jul 13 02:30:09 2003)
    MySQL-server is not up to date (Thu Feb 12 18:03:01 2004)
    error: open of /var/spool/cpupdates/MySQL-server-4.0.20-0.i386.rpm failed: No such file or
    irectory
    MySQL-embedded is not up to date (Thu Feb 12 18:03:01 2004)
    error: open of /var/spool/cpupdates/MySQL-embedded-4.0.20-0.i386.rpm failed: No such file or directory
    MySQL-client is not up to date (Thu Feb 12 18:03:01 2004)
    error: open of /var/spool/cpupdates/MySQL-client-4.0.20-0.i386.rpm failed: No such file or directory
    MySQL-devel is not up to date (Thu Feb 12 18:03:01 2004)
    error: open of /var/spool/cpupdates/MySQL-devel-4.0.20-0.i386.rpm failed: No such file or directory
    MySQL-bench is not up to date (Thu Feb 12 18:03:01 2004)
    error: open of /var/spool/cpupdates/MySQL-bench-4.0.20-0.i386.rpm failed: No such file or directory
    MySQL-shared is not up to date (Thu Feb 12 18:03:01 2004)
    error: open of /var/spool/cpupdates/MySQL-shared-4.0.20-0.i386.rpm failed: No such file or directory
    MySQL-shared-compat is not up to date (Fri Feb 13 10:25:16 2004)
    error: open of /var/spool/cpupdates/MySQL-shared-compat-4.0.20-0.i386.rpm failed: No such file or directory
    portsentry is up to date (Wed Jan 30 03:02:40 2002)
     
  2. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16
    in WHM

    Tweak settings
    MySQL Version to use (you must run Software/Update Server Software (or /scripts/sysup) for this to take affect. You should then run buildapache/easyapache after changing this option. MySQL 4 is not avalible on glibc-2.1 or below platforms)

    check mark 4

    save

    follow the directions after that.

    if that dont work..

    /scripts/upcp --force
     
  3. adapter

    adapter Well-Known Member
    PartnerNOC

    Joined:
    Sep 17, 2003
    Messages:
    391
    Likes Received:
    0
    Trophy Points:
    16
    no way i have run also /scripts/upcp --force but when i run again /scripts/sysup i get the above error, this happend also on my other 3 Rh9 servers :(
     
Loading...

Share This Page