MySQL Upgrade (those 7 steps)

MyDreamscape

Member
Apr 27, 2010
6
1
53
Netherlands
Hit there,

I am absolutely unfamiliar with servers but WHM "forces" me to upgrade MySQL and PHP else no WHM and cPanel updates posible it says.

Is it possible to do both (MySQL/PHP) through WHM without any hassle?

What I would like to know: what will be asked/what I have to do, during those famous 7 steps. Which info do I need to "feed" the server with? Is there a list with those (7)steps? Also reading everywhere that php won't work afterwards and therefore also has to be upgraded.

Looking forward finding help/information.
 

MyDreamscape

Member
Apr 27, 2010
6
1
53
Netherlands
Additonal information (sorry can't edit own thread?):

MySQL Currently installed: 5.0.96 / CENTOS 5.10 x86_64 / WHM 11.44.1 (build 18) / cPanel Version 11.44.1 (build 18).
 

server9host

Well-Known Member
Sep 18, 2013
160
0
16
India
cPanel Access Level
Root Administrator
Hello,

For updating mysql you need to perform easyapache.

Let me know which PHP version you are currently use. Because for new cPanel update need to perform easyapache on server and in easyapache above 5.3
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Hello :)

Yes, it's possible to upgrade both MySQL and Apache/PHP through Web Host Manager. In fact, the MySQL Upgrade interface will take you through all of the steps to complete this. The MySQL upgrade process is documented here:

MySQL Upgrade

Thank you.
 

MyDreamscape

Member
Apr 27, 2010
6
1
53
Netherlands
Hi there,

Specs shown in cPanel:

cPanel Version 11.44.1 (build 18)
Apache version 2.0.63
PHP version 5.2.9
MySQL version 5.0.96-community
Architecture x86_64
Perl version 5.8.8
Kernel version 2.6.32.60xls-domU
cPanel Pro 1.0 (RC1)

(all is on a production server, we have no dev server to test else it would been done probably)

What do you mean by "perform easyapache" ?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Please keep in mind that your PHP version will upgrade to 5.3 by default because version 5.2 is no longer offered in EasyApache.

Thank you.
 

server9host

Well-Known Member
Sep 18, 2013
160
0
16
India
cPanel Access Level
Root Administrator
Hello,

Please confirm with your developer regarding your site will work on PHP version 5.3 and above. Because after upgrade the PHP version it's very difficult task to downgrade the PHP version on server.

Or one more option you can use cloud link feature to use multiple PHP version in same server. Using this feature you can upgrade php version with latest version and use php 5.2 to for your all websites.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
208
cPanel Access Level
DataCenter Provider
Hit there,

Is it possible to do both (MySQL/PHP) through WHM without any hassle?

....Also reading everywhere that php won't work afterwards and therefore also has to be upgraded.

Looking forward finding help/information.

cPanel & WHM version 11.44.1.15 and later contains significant improvements to the MySQL Upgrade tool. The new version of the MySQL Upgrade tool also allows you to defer the rebuild of Apache and PHP. We strongly recommend that you update cPanel & WHM to version 11.44.1.15 before you update MySQL®.