The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL will not re-install

Discussion in 'Database Discussions' started by entyse, Aug 10, 2005.

  1. entyse

    entyse Member

    Joined:
    Aug 9, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    After a clean install I couldn't log into phpmyadmin. I then realized that mysql 4.1 was wiped.......
    I then tried to reload it and can't get mysql 4.1 to reload from /scripts/mysqlup

    I get a ton of errors...

    "no mysql.sock found" etc.etc....

    I then did this

    /scripts/sysup I get a fedora 4 not supported
    /scripts/rpmup runs fine
    /scripts/mysqlup --force still get all the erros again.......

    error: open of </html> failed: No such file or directory
    Warning, no valid mysql.sock file found.
    mysql has failed

    Has anyone gotten this to work on Fedora core 4????

    thanks!
     
  2. shashank

    shashank Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    159
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    You might need to install all these rpms from

    http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/

    manually.

    [ ] mysql-4.1.11-2.i386.rpm 20-May-2005 15:00 3.6M
    [ ] mysql-bench-4.1.11-2.i386.rpm 20-May-2005 15:00 498K
    [ ] mysql-devel-4.1.11-2.i386.rpm 20-May-2005 15:00 1.9M
    [ ] mysql-server-4.1.11-2.i386.rpm 20-May-2005 15:00 6.4M
    [ ] mysqlclient10-3.23.58-6.i386.rpm 20-May-2005 13:25 231K
    [ ] mysqlclient10-devel-3.23.58-6..> 20-May-2005 13:25 48K

    A running cpanel server has the following ones installed.

    MySQL-bench-4.1.11-0
    perl-DBD-MySQL-2.9003-5
    MySQL-embedded-4.1.11-0
    MySQL-shared-4.1.11-0
    MySQL-devel-4.1.11-0
    MySQL-server-4.1.11-0
    MySQL-shared-compat-4.1.11-0
    MySQL-client-4.1.11-0

    Choose the rpms carefully and install them.
     
  3. entyse

    entyse Member

    Joined:
    Aug 9, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    That did it thank you ....... :)
     
  4. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Well. If you install this packages, Apache fails, becaase can't compiling with apropiate mysqlclient libraries.

    Any solution?

    Of course the apropiate solutions it's:

    If Cpanel.net put in your pages "Support Fedora 1,2,3,4" and get money for several licenses, it's, MySQL for Fedora 1,2,3,4... if considering Fedora 4 not production enviroment, please don't put on cpanel.net pages.
     
Loading...

Share This Page