Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysql will not start

Discussion in 'Database Discussions' started by rhm.geerts, Dec 5, 2017.

  1. rhm.geerts

    rhm.geerts Well-Known Member

    Joined:
    Jul 29, 2008
    Messages:
    62
    Likes Received:
    5
    Trophy Points:
    58
    Location:
    Maastricht
    cPanel Access Level:
    Root Administrator
    Just installed a new Centos 7 server with Cpanel.
    Wanted to create a new main user, but that would not work because Mysql was not running.

    Can't start mysql, the log is stating this:
    Code:
    171206 02:47:20 mysqld_safe mysqld from pid file /var/lib/mysql/srv.domainname.nl.pid ended
    171206 02:47:36 mysqld_safe Logging to '/var/lib/mysql/srv.domainname.nl.err'.
    171206 02:47:36 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    2017-12-06 02:47:36 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp se
    rver option (see documentation for more details).
    2017-12-06 02:47:36 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated
     files. Consider setting it to a valid, non-empty path.
    2017-12-06 02:47:36 0 [Note] /usr/sbin/mysqld (mysqld 5.6.38) starting as process 2946 ...
    2017-12-06 02:47:36 2946 [Note] Plugin 'FEDERATED' is disabled.
    2017-12-06 02:47:36 2946 [Note] InnoDB: Using atomics to ref count buffer pool pages
    2017-12-06 02:47:36 2946 [Note] InnoDB: The InnoDB memory heap is disabled
    2017-12-06 02:47:36 2946 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
    2017-12-06 02:47:36 2946 [Note] InnoDB: Memory barrier is not used
    2017-12-06 02:47:36 2946 [Note] InnoDB: Compressed tables use zlib 1.2.3
    2017-12-06 02:47:36 2946 [Note] InnoDB: Using Linux native AIO
    2017-12-06 02:47:36 2946 [Note] InnoDB: Using CPU crc32 instructions
    2017-12-06 02:47:36 2946 /usr/sbin/mysqld: Can't create/write to file '/mysqltmp/ibysu3zM' (Errcode: 2 - No such file or directory)
    2017-12-06 02:47:36 7fc686470740  InnoDB: Error: unable to create temporary file; errno: 2
    2017-12-06 02:47:36 2946 [ERROR] Plugin 'InnoDB' init function returned error.
    2017-12-06 02:47:36 2946 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    2017-12-06 02:47:36 2946 [ERROR] Unknown/unsupported storage engine: InnoDB
    2017-12-06 02:47:36 2946 [ERROR] Aborting
    This is the my.cnf:
    Code:
    [mysqld]
    max_connections=500
    # safe-show-database
    local-infile=0
    max_allowed_packet=268435456
    innodb_buffer_pool_size=512M
    innodb_lock_wait_timeout=180
    open_files_limit=22506
    tmpdir="/mysqltmp"
    default-storage-engine=MyISAM
    innodb_file_per_table=1
    It looks like mysql can't write a tmp file. The only thing I did for tmp is to run the /scripts/securetmp script.
    The directory /mysqlmp does not exist, and even if I create it as root, mysql will not start.

    Edit: Just checked something else.
    /etc/systemd/system does not contain any mysqld.service but there is a mysql.service file. I don't know if that is important.
     
  2. rhm.geerts

    rhm.geerts Well-Known Member

    Joined:
    Jul 29, 2008
    Messages:
    62
    Likes Received:
    5
    Trophy Points:
    58
    Location:
    Maastricht
    cPanel Access Level:
    Root Administrator
    Is this some cpanel issue? If I check the mysql status, then the mysql server is running using the mysql.service. But I can't restart it from cpanel whm because that is trying to restart a non-existing mysqld.service file if I'm correct.

    • CENTOS 7.4 standard [srv]
    • v68.0.19
     
    #2 rhm.geerts, Dec 5, 2017
    Last edited by a moderator: Dec 6, 2017
  3. rhm.geerts

    rhm.geerts Well-Known Member

    Joined:
    Jul 29, 2008
    Messages:
    62
    Likes Received:
    5
    Trophy Points:
    58
    Location:
    Maastricht
    cPanel Access Level:
    Root Administrator
    Stupid me. Just overlooked a setting I put in the my.cnf myself.
    This is solved, topic can be closed.
     
    cPanelMichael likes this.
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,396
    Likes Received:
    1,605
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see the issue is now solved. Could you let us know the specific setting that caused the issue?

    Thank you.
     
Loading...

Share This Page