The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL

Discussion in 'General Discussion' started by B12Org, Oct 29, 2003.

  1. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    MySQL is not working, and the system temp dir is empty. I rebooted the server and there are two session files, however no mysql databases are working. I get can not connect to database errors, and everything is setup correctly, was working fine an hour ago. Mysql has been restarted and is not reporting any ideas. Any Ideas?
     
  2. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    Same here on one server. Did you fix it?
     
  3. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    Yes, it seems that mysql.sock was missing, so I created a sym link ln -s from its original place, and placed one there, and restarted mysql. Then ran sysupdate and upcp just to be safe, and then did: (all one command line)

    service cpanel stop ; service cpanel start ; /scripts/updatenow ; /scripts/sysup ; /scripts/upcp ; /scripts/restartsrv mysql

    Worked after that.
     
  4. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    When I try to create the link it tells me things like file already exists etc.

    Can you tell me what command exactly to use to fix it?
     
  5. shaun

    shaun Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    698
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Clemente, Ca
    NNNils: are you sure mysql is running?
     
  6. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    Datacenter fixed it for me.
     
Loading...

Share This Page