Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mysql5.6 and Mariadb5.5 conflicting when trying to update

Discussion in 'Database Discussion' started by David_spm, Jan 24, 2019.

  1. David_spm

    David_spm Well-Known Member

    Joined:
    May 28, 2017
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thailand
    cPanel Access Level:
    Root Administrator
    Currently on Mariadb5.5 and trying to update to 10 via the GUI. Followed the instructions and when running the unattended upgrade it fails with this error below. The first few lines are repeated with many files seemingly conflicting between the two.

    Please advise, thanks.

    Code:
    [2019-01-24 23:13:50 -0500] file /usr/include/mysql/typelib.h from install of MySQL56-devel-5.6.41-1.cp1162.x86_64 conflicts with file from package MariaDB-devel-5.5.62-1.el6.x86_64
    [2019-01-24 23:13:50 -0500] file /usr/share/aclocal/mysql.m4 from install of MySQL56-devel-5.6.41-1.cp1162.x86_64 conflicts with file from package MariaDB-devel-5.5.62-1.el6.x86_64
    [2019-01-24 23:13:50 -0500] file /usr/share/man/man1/mysql_config.1.gz from install of MySQL56-devel-5.6.41-1.cp1162.x86_64 conflicts with file from package MariaDB-devel-5.5.62-1.el6.x86_64
    [2019-01-24 23:13:50 -0500] W Error Code: 8
    [2019-01-24 23:13:50 -0500] Hooks system enabled.
    [2019-01-24 23:13:50 -0500] Checking for and running RPM::Versions 'post' hooks for any RPMs about to be installed
    [2019-01-24 23:13:50 -0500] All required 'post' hooks have been run
    [2019-01-24 23:13:50 -0500] Restoring service monitoring.
    Restarting mysql service.
    Waiting for “mysql” to restart ……waiting for “mysql” to initialize ………finished.
    
    Service Status
    mysql (/usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --user=mysql --log-error=/var/lib/mysql/server.imand.com.err --open-files-limit=132768 --pid-file=/var/lib/mysql/server.imand.com.pid) is running as mysql with PID 30196 (pidfile+/proc check method).
    
    Startup Log
    Starting MariaDB.190124 23:13:57 mysqld_safe Logging to '/var/lib/mysql/server.imand.com.err'.
    190124 23:13:57 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    ... SUCCESS!
    
    Log Messages
    190124 23:13:59 [Note] /usr/sbin/mysqld: ready for connections.
    190124 23:13:57 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    190124 23:13:56 mysqld_safe mysqld from pid file /var/lib/mysql/server.imand.com.pid ended
    190124 23:13:56 [Note] /usr/sbin/mysqld: Shutdown complete
    190124 23:13:51 [Note] /usr/sbin/mysqld: Normal shutdown
    190124 23:11:21 [Note] /usr/sbin/mysqld: ready for connections.
    
    mysql restarted successfully.
    We expected to upgrade to 5.6; however, the system is currently on version 5.5. at /usr/local/cpanel/Whostmgr/Mysql/Upgrade.pm line 894.
    Obtained version information from system.
    Proceeding with MySQL/MariaDB upgrade despite the following:
    Normal: The selected MariaDB version (10.0) is more than one generation newer than the currently installed version. The upgrade process will iterate over each intervening version to ensure tables are upgraded appropriately.
     
  2. David_spm

    David_spm Well-Known Member

    Joined:
    May 28, 2017
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thailand
    cPanel Access Level:
    Root Administrator
    OK so there was some important info at the start of the error output too. Please see below for that, I tried the check_cpanel_rpms --fix and then retried this but it returns the same error:

    Code:
    Obtained version information from system.
    Ensuring MySQL RPMs for version “5.6”.
    Running: /usr/local/cpanel/scripts/check_cpanel_rpms --targets=MySQL41,MySQL50,MySQL51,MySQL55,MySQL56,MySQL57,MariaDB100,MariaDB101,MariaDB102 --fix
    [2019-01-24 23:30:36 -0500]
    [2019-01-24 23:30:36 -0500] Problems were detected with cPanel-provided files which are RPM controlled.
    [2019-01-24 23:30:36 -0500] If you did not make these changes intentionally, you can correct them by running:
    [2019-01-24 23:30:36 -0500]
    [2019-01-24 23:30:36 -0500] > /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    [2019-01-24 23:30:36 -0500] The following RPMs are missing from your system:
    [2019-01-24 23:30:36 -0500] MySQL56-client-5.6.41-1.cp1162
    [2019-01-24 23:30:36 -0500] MySQL56-devel-5.6.41-1.cp1162
    [2019-01-24 23:30:36 -0500] MySQL56-server-5.6.41-1.cp1162
    [2019-01-24 23:30:36 -0500] MySQL56-shared-5.6.41-1.cp1162
    [2019-01-24 23:30:36 -0500] MySQL56-test-5.6.41-1.cp1162
    [2019-01-24 23:30:36 -0500] compat-MySQL50-shared-5.0.96-4.cp1136
    [2019-01-24 23:30:36 -0500] compat-MySQL51-shared-5.1.73-1.cp1150
    [2019-01-24 23:30:36 -0500] Removing 0 broken rpms:
    [2019-01-24 23:30:36 -0500] rpm: no packages given for erase
    [2019-01-24 23:30:38 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.62/centos/6/x86_64/rpm.sha512
    [2019-01-24 23:30:38 -0500] Successfully verified signature for cpanel (key types: release).
    [2019-01-24 23:30:38 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/rpm.sha512
    [2019-01-24 23:30:38 -0500] Successfully verified signature for cpanel (key types: release).
    [2019-01-24 23:30:38 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.50/centos/6/x86_64/rpm.sha512
    [2019-01-24 23:30:38 -0500] Successfully verified signature for cpanel (key types: release).
    [2019-01-24 23:30:38 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.62/centos/6/x86_64/MySQL56-client-5.6.41-1.cp1162.x86_64.rpm
    [2019-01-24 23:30:39 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.62/centos/6/x86_64/MySQL56-server-5.6.41-1.cp1162.x86_64.rpm
    [2019-01-24 23:30:42 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.62/centos/6/x86_64/MySQL56-test-5.6.41-1.cp1162.x86_64.rpm
    [2019-01-24 23:30:46 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.50/centos/6/x86_64/compat-MySQL51-shared-5.1.73-1.cp1150.x86_64.rpm
    [2019-01-24 23:30:46 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.62/centos/6/x86_64/MySQL56-devel-5.6.41-1.cp1162.x86_64.rpm
    [2019-01-24 23:30:47 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.62/centos/6/x86_64/MySQL56-shared-5.6.41-1.cp1162.x86_64.rpm
    [2019-01-24 23:30:47 -0500] Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/compat-MySQL50-shared-5.0.96-4.cp1136.x86_64.rpm
    [2019-01-24 23:30:47 -0500] Disabling service monitoring.
    [2019-01-24 23:30:48 -0500] Hooks system enabled.
    [2019-01-24 23:30:48 -0500] Checking for and running RPM::Versions 'pre' hooks for any RPMs about to be installed
    [2019-01-24 23:30:48 -0500] All required 'pre' hooks have been run
    [2019-01-24 23:30:48 -0500] No RPMS need to be uninstalled
    [2019-01-24 23:30:48 -0500] Installing new rpms: MySQL56-client-5.6.41-1.cp1162.x86_64.rpm MySQL56-devel-5.6.41-1.cp1162.x86_64.rpm MySQL56-server-5.6.41-1.cp1162.x86_64.rpm MySQL56-shared-5.6.41-1.cp1162.x86_64.rpm MySQL56-test-5.6.41-1.cp1162.x86_64.rpm compat-MySQL50-shared-5.0.96-4.cp1136.x86_64.rpm compat-MySQL51-shared-5.1.73-1.cp1150.x86_64.rpm
    [2019-01-24 23:30:48 -0500] Preparing packages for installation...
     
  3. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,476
    Likes Received:
    507
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @David_spm


    Can you tell me what version of MySQL/MariaDB you're running right now? You can find this by running:

    Code:
    mysql -v 
    Can you also run the following:

    Code:
    rpm -qa |egrep -i 'maria|mysql'
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. David_spm

    David_spm Well-Known Member

    Joined:
    May 28, 2017
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thailand
    cPanel Access Level:
    Root Administrator
    Sure here it is

    Server version: 5.5.62-MariaDB MariaDB Server

     
  5. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,476
    Likes Received:
    507
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Ahh interesting. What about the command I gave you?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. David_spm

    David_spm Well-Known Member

    Joined:
    May 28, 2017
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thailand
    cPanel Access Level:
    Root Administrator
    Sorry I forgot to add that, here you go:

    Code:
    MariaDB-devel-5.5.63-1.el6.x86_64
    cpanel-mysql-libs-5.1.73-1.cp1156.x86_64
    cpanel-mysql-5.1.73-1.cp1156.x86_64
    ea-php56-php-mysqlnd-5.6.40-2.2.2.cpanel.x86_64
    cpanel-mariadb-connector-devel-3.0.3-3.cp1174.x86_64
    cpanel-perl-526-DBD-mysql-4.046_01-3.cp1174.x86_64
    MariaDB-common-5.5.63-1.el6.x86_64
    perl-DBD-MySQL-4.013-3.el6.x86_64
    MariaDB-client-5.5.63-1.el6.x86_64
    ea-php71-php-mysqlnd-7.1.26-2.2.2.cpanel.x86_64
    ea-php70-php-mysqlnd-7.0.33-2.2.2.cpanel.x86_64
    MariaDB-compat-5.5.63-1.el6.x86_64
    cpanel-mariadb-connector-3.0.3-3.cp1174.x86_64
    cpanel-perl-526-MySQL-Diff-0.50-1.cp1170.noarch
    MariaDB-server-5.5.63-1.el6.x86_64
    
    so what is causing this?
     
  7. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,476
    Likes Received:
    507
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @David_spm

    I believe this is being caused due to the MariaDB package you're using and i think it would also explain the MySQL confusion earlier on. MariaDB 5.5 is MariaDB + MySQL 5.5. We don't support this package and they do give instructions on how to move to just MariaDB 10.0 here Upgrading from MariaDB 5.5 to MariaDB 10.0 but if you're unsure I'd suggest enlisting the assistance of a qualified system administrator you might find one at System Administration Services | cPanel Forums if you don't have one already.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. David_spm

    David_spm Well-Known Member

    Joined:
    May 28, 2017
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thailand
    cPanel Access Level:
    Root Administrator
    OK thanks, will do that
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice