Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mystery - not receiving some email (GMail+Yahoo work, etc)

Discussion in 'E-mail Discussion' started by IDDQD, Sep 4, 2013.

  1. IDDQD

    IDDQD Registered

    Joined:
    Sep 4, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    (SOLVED) Mystery - not receiving some email (GMail+Yahoo work, etc)

    SOLVED: I guess it was a DNS issue after all, just a moment ago I managed to receive mail from FastMail. Yey!

    Hi all,

    I have this strange thing going on with my new (got it delivered just yesterday) cPanel/WHM installation, lets call this Box A.

    Case:

    Background:

    From Box A, I can send/receive emails to/from GMail+Yahoo fine, and also my other VPS mailserver (Box B, not cPanel/WHM) works fine with sending/receiving so in that wise the Box A is working fine!

    I also do have account with http://fastmail.fm - and I can send/receive emails from there to Yahoo, GMail and Box B, been having this account for years without problems so it seems to work fine!

    Problem is:

    But for some mysterious reason, IF I try sending email from that FastMail account TO my Box A, nothing happens - nothing in mail logs, no bounce error message back... Altho I can send email from Box A to FastMail.

    WTF now.. Box A and FastMail seem to work just fine standalone, and BoxA->FastMail works also.

    I have tried many things, quadruple checked NS records, tried changing between dovecot and courier, making different accounts to Box A, and made even a forwarder in Box A, but problem persist - not any single message from FastMail to Box A gets delivered, actually they seem to disappear completely!

    Any ideas that might shed a light to this matter are appreciated greatly!

    I have also submitted a support ticket to FastMail if they have something in their logs regarding those lost mails.

    Thanks in Advance,

    IDDQD :)
     
    #1 IDDQD, Sep 4, 2013
    Last edited: Sep 5, 2013
  2. IDDQD

    IDDQD Registered

    Joined:
    Sep 4, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Update to this matter - I made an addon domain to my main account, AND I was able to send/receive emails just fine from it, EVEN to/from FastMail..

    So this problem only concerns my main hosting domain, which cannot receive mails from FastMail service.

    To clarify this, anything@hostingdomain.com cannot receive mail from FM, and anything@hostingdomains-addon-domain.com on the same server can... WTF is going on? :S
     
  3. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,888
    Likes Received:
    90
    Trophy Points:
    78
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    Have you checked your mail logs ? Through mail logs you can find out why your are facing this issues with your main hosting account.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,116
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    I am happy to hear you were able to resolve the issue. Thank you for updating your post to let us know.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice