The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

name server problem

Discussion in 'General Discussion' started by totalufo, Mar 23, 2002.

  1. totalufo

    totalufo Well-Known Member

    Joined:
    Jan 17, 2002
    Messages:
    160
    Likes Received:
    0
    Trophy Points:
    16
    I have a client that has signed up as a reseller. I had him register name servers. His first one points to the IP of the server and then a second IP for the secondary name server.

    The problem he is having is that when he set up a non-ip domain account, which uses the IP of the server, he can't get the site to show up. All of his other domains work but just one doesn't.

    When he pings the domain, it gives back the proper IP but it is not viewable in the browser.

    I read in another post that you cannot use the same IP for multiple name servers. This doesn't seem to be true because it's working for all other domains.

    Anyone have an idea of what the problem could be or how I should troubleshoot this?

    At one time, he could see the site but now he can't.

    also, his zone file for the domain looks correct. Any ideas?
     
  2. bjarne

    bjarne Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    shuld be in arpa net

    Hi!

    A domain name server name shuld resolv to an IP, but also the IP shuld resolve to the nameservername. In some countrys they will not registrer a domain if the nameservers IP don't resolve to the nameserver. You basicly shuld not use the same IP for several nameservers. You can, and it is common - have several IPs bind to the same server.

    You are basicly trying to screw things up - I belive.

    Don't understand how whm handles dns yet, so cant help there. But it sounds like a mess to have diffrent nameservers on one box. Yes you can run master/slave on two Ips, but they have the same SOA records and the same emailadress.
     
  3. totalufo

    totalufo Well-Known Member

    Joined:
    Jan 17, 2002
    Messages:
    160
    Likes Received:
    0
    Trophy Points:
    16
    I found the problem and is simlar to what you are saying. My client is was still running his old name server on another machine confusing everything.
     
Loading...

Share This Page