Nirjonadda

Well-Known Member
May 8, 2013
736
27
78
cPanel Access Level
Root Administrator
I am getting this WARNING.

Code:
WARNING: Name servers software versions are exposed:
 "PowerDNSAuthoritativeServer3.4.10([email protected]@rpmbuild-64-centos-7.dev.cpanel.net)"
Exposing name server's versions may be risky, when a new vulnerability is found your name servers may be automatically exploited by script kiddies until you patch the system.

One or more nameservers responded to version queries. This can be considered a breach of security. If a malicious person or program had access to a version-specific exploit for your DNS server, displaying the version info openly will make their attack much easier. This should be removed or obscured. The nameservers that responded to version queries are:

Code:
IP responded with "PowerDNS" "Authoritative" "Server" "3.4.10" "([email protected]" "built" "20170306160718" "[email protected])"
 
Last edited by a moderator:

cPanelJasonT

Level 2 Technical Analyst
Staff member
Oct 21, 2014
54
6
83
cPanel Access Level
Root Administrator
Hello,
This version string reporting can be changed by setting the following in /etc/pdns/pdns.conf:
Code:
version-string=anonymous
 

joaocosta

Member
Apr 17, 2021
10
0
1
FZZ - Portugal
cPanel Access Level
Reseller Owner
I would expect that file to exist on cPanel machines using PowerDNS. Are you trying to edit that file as the root user? I see this on a test machine:

Code:
# ll /etc/pdns/pdns.conf
-rw-------. 1 named named 18K Mar  8 01:59 /etc/pdns/pdns.conf
Hi cPRex,

Thank you for your help :)

First, I loved your nickname, it's brutal :)

Second, I ran the same command that you displayed and the result is this:

Code:
[root @ earth ~] # ll /etc/pnds/pnds.conf
ls: cannot access '/etc/pnds/pnds.conf': No such file or directory
[root @ earth ~] #
Regards
 

joaocosta

Member
Apr 17, 2021
10
0
1
FZZ - Portugal
cPanel Access Level
Reseller Owner
Hi cPRex,

I already found out where the error was ... It was in me, because I was typing /etc/pnds/pnds.conf instead of typing /etc/pdns/pdns.conf

Two little letters exchanged and so it gave error :(

Regards