SOLVED named[8710]: none:104: 'max-cache-size 90%' - setting to 14259MB (out of 15843MB)

Operating System & Version
CENTOS 7.9
cPanel & WHM Version
v92.0.11

risecompany

Member
Mar 10, 2015
9
0
51
Egypt
cPanel Access Level
Root Administrator
Hi,

While Restarting DNS Server, I get an alert " server named[8710]: none:104: 'max-cache-size 90%' - setting to 14259MB (out of 15843MB) "
How we can solve this issue ?
 
Last edited by a moderator:

risecompany

Member
Mar 10, 2015
9
0
51
Egypt
cPanel Access Level
Root Administrator
Code:
Restarting DNS Server
Waiting for “bind” to restart ………waiting for “named” to initialize ………finished.

Service Status
named (/usr/sbin/named -u named -c /etc/named.conf) is running as named with PID 25312 (systemd+/proc check method).

Startup Log
Mar 03 01:08:27 mysite.com named[25312]: automatic empty zone: view internal: A.E.F.IP6.ARPA
Mar 03 01:08:27 mysite.com named[25312]: automatic empty zone: view internal: B.E.F.IP6.ARPA
Mar 03 01:08:27 mysite.com named[25312]: automatic empty zone: view internal: 8.B.D.0.1.0.0.2.IP6.ARPA
Mar 03 01:08:27 mysite.com named[25312]: automatic empty zone: view internal: EMPTY.AS112.ARPA
Mar 03 01:08:27 mysite.com named[25312]: automatic empty zone: view internal: HOME.ARPA
Mar 03 01:08:27 mysite.com named[25312]: none:104: 'max-cache-size 90%' - setting to 14259MB (out of 15843MB)
Mar 03 01:08:27 mysite.com named[25312]: set up managed keys zone for view external, file 'external.mkeys'
Mar 03 01:08:27 mysite.com named[25312]: none:104: 'max-cache-size 90%' - setting to 14259MB (out of 15843MB)
Mar 03 01:08:27 mysite.com named[25312]: command channel listening on 127.0.0.1#953
Mar 03 01:08:27 mysite.com systemd[1]: Started Berkeley Internet Name Domain (DNS).

Log Messages
Mar 3 01:08:27 server named[25312]: command channel listening on 127.0.0.1#953
Mar 3 01:08:27 server named[25312]: none:104: 'max-cache-size 90%' - setting to 14259MB (out of 15843MB)
Mar 3 01:08:27 server named[25312]: set up managed keys zone for view external, file 'external.mkeys'
Mar 3 01:08:27 server named[25312]: none:104: 'max-cache-size 90%' - setting to 14259MB (out of 15843MB)

named restarted successfully.
Here : Home »Restart Services »DNS Server »Restarting DNS Server
After Restarting i receive 'max-cache-size 90%' wondering what is the issue here ?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,399
553
273
cPanel Access Level
Root Administrator
Thanks for the additional details. I just wanted to confirm the service was actually working as intended before going further than that.

This isn't necessarily an issue, as this is the default behavior for a BIND nameserver. Here is what I see on a CentOS 7 server when I restart named:

Code:
Log Messages
    Mar  3 07:31:58 10-2-33-26 named[27845]: command channel listening on 127.0.0.1#953
    Mar  3 07:31:58 10-2-33-26 named[27845]: none:104: 'max-cache-size 90%' - setting to 1798MB (out of 1998MB)
    Mar  3 07:31:58 10-2-33-26 named[27845]: set up managed keys zone for view external, file 'external.mkeys'
    Mar  3 07:31:58 10-2-33-26 named[27845]: none:104: 'max-cache-size 90%' - setting to 1798MB (out of 1998MB)
I did try adding the value to the named.conf file as outlined here:


but that caused startup errors.

If you want to ensure the named system will use less RAM, you may want to think about switching over to PowerDNS, as that is the DNS server we include with all new installations of cPanel at this time.
 
  • Like
Reactions: risecompany

risecompany

Member
Mar 10, 2015
9
0
51
Egypt
cPanel Access Level
Root Administrator
If this is the default behavior, So i don't have an issue with that ? I am safe right ?
I just want to prevent any potential issue from that message in the future.
 

risecompany

Member
Mar 10, 2015
9
0
51
Egypt
cPanel Access Level
Root Administrator
Thanks for your support, I really appreciate that, another thing if you please i tried now to upgrade to PowerDNS, but i found that message :
" PowerDNS is not available for your system. Please choose another nameserver configuration. "
How can i enable it?
 

risecompany

Member
Mar 10, 2015
9
0
51
Egypt
cPanel Access Level
Root Administrator
CENTOS 7.9 - v94.0.2
----------------
search mysite.com
domain mysite.com
nameserver 143.95.37.111
nameserver 143.95.224.222
nameserver 8.8.8.8

* for security i replaced mysite.com / 111/ 222
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,399
553
273
cPanel Access Level
Root Administrator
Thanks for that - is one of those first two "nameserver" entries also a local IP address? If so, that would need to be removed in order to use PowerDNS as that software has to use external resolvers. You could try using the following entries in the /etc/resolv.conf file:

Code:
nameserver 8.8.8.8
nameserver 8.8.4.4
as those are both the Google public resolvers.

If it still doesn't let you switch after that, or if those IP addresses are not local, please let me know!
 
  • Like
Reactions: risecompany