The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Named failing

Discussion in 'General Discussion' started by taproot, Apr 2, 2009.

  1. taproot

    taproot Well-Known Member

    Joined:
    Aug 22, 2008
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    I have received this message a few times in the past 9 hours. Anyone have any idea why the ownership would be getting messed up as indicated by the error?

    nameserver failed @ Wed Apr 1 23:07:29 2009. A restart was attempted automagically.
    Service Check Method: [check command]

    Cmd Service Check Raw Output: Fixed ownership on /etc/named.conf
    Fixed ownership on /etc/rndc.key
    Fixed ownership on /etc/rndc.conf

    Cheers,
    TR
     
  2. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    We are getting this one again now. Same exact symptom.

    I would really like someone from cpanel technical to respond to this one at this juncture. Thanks.
     
  3. Ancile

    Ancile Member

    Joined:
    Jun 26, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1


    Same issue here, fixed after deleting one domain record that was apparently 'out of range' ??? - How can one dns record screw DNS for over 400 zones?
     
    #3 Ancile, Jul 4, 2009
    Last edited: Jul 4, 2009
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    198
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might want to put in a ticket with cPanel support so they can take a look for you.
     
  5. iUnknown

    iUnknown Member

    Joined:
    Jul 11, 2008
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel! I hope you read this, I have had exactly the same problem, and have asked other people with cPanel servers and they say the same. It's on the stable build, and it caused downtime for my clients. DNS is now running but it also rebuilt some DNS zones. I've managed to restore some of the complex ones (with many subdomains) from backups.

    I have been experiencing some strange DNS messages and issues with the DNS zones rebuilding over the last couple of weeks - just after the automatic cPanel update runs. Perhaps there's a bug that you've missed?

    Thanks.
     
  6. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    One more.. exact same issue on a cPanel box running latest Release versio tree..

    ANy news from cPanel?
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I concur with Infopro, to anyone experiencing this issue - please submit a support ticket so we can properly diagnose this issue and take corrective action: http://tickets.cPanel.net/submit
     
  8. rajinnasik

    rajinnasik Member

    Joined:
    Nov 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I have just got same email notification as below:

    ---------------------------------------------------
    nameserver failed @ Wed Dec 15 05:17:57 2010. A restart was attempted automagically.
    Service Check Method: [check command]

    Cmd Service Check Raw Output: Fixed ownership on /etc/named.conf
    Fixed ownership on /etc/rndc.key
    Fixed ownership on /etc/rndc.conf
    ---------------------------------------------------

    So did anyone find info to diagnose this issue yet?
    If yes, please share with us :)
     
  9. drsinger111

    drsinger111 Member

    Joined:
    Feb 21, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    In getting this error last night...

    nameserver failed @ Wed Dec 15 01:46:06 2010. A restart was attempted automagically.
    Service Check Method: [check command]

    Cmd Service Check Raw Output: Fixed ownership on /etc/named.conf
    Fixed ownership on /etc/rndc.key
    Fixed ownership on /etc/rndc.conf

    I checked the yum logs for updates, i'm seeing:

    tac /var/log/yum.log |less

    Dec 15 00:16:48 Updated: 30:caching-nameserver-9.3.6-4.P1.el5_5.3.x86_64
    Dec 15 00:16:48 Updated: 30:bind-devel-9.3.6-4.P1.el5_5.3.i386
    Dec 15 00:16:46 Updated: openssl-devel-0.9.8e-12.el5_5.7.x86_64
    Dec 15 00:16:44 Updated: 30:bind-devel-9.3.6-4.P1.el5_5.3.x86_64
    Dec 15 00:16:40 Updated: openssl-devel-0.9.8e-12.el5_5.7.i386
    Dec 15 00:16:38 Updated: 30:bind-utils-9.3.6-4.P1.el5_5.3.x86_64
    Dec 15 00:16:37 Updated: 30:bind-9.3.6-4.P1.el5_5.3.x86_64
    Dec 15 00:16:36 Updated: 30:bind-libs-9.3.6-4.P1.el5_5.3.i386
    Dec 15 00:16:36 Updated: 30:bind-libs-9.3.6-4.P1.el5_5.3.x86_64
    Dec 15 00:16:35 Updated: openssl-0.9.8e-12.el5_5.7.x86_64

    so, checking for errors;

    tac /var/log/messages |grep named |less

    getting this;

    Dec 15 10:13:49 host named[24058]: max open files (1024) is smaller than max sockets (4096)
    Dec 15 10:13:49 host named[24058]: loading configuration from '/etc/named.conf'
    Dec 15 10:13:49 host named[24058]: using up to 4096 sockets

    (this is in reverse order because i'm using tac as opposed to cat)

    resolution may be here;
    [CentOS] BIND and latest update (max open files WARNING)

    ===============================================

    After the latest security update for bind (which came out last night), now
    there's a new message on syslog, (facility: daemon, severity: warning) every
    time you restart named:

    max open files (1024) is smaller than max sockets (4096)

    After googling for a while the solution seems to be to add this to
    /etc/security/limits.conf:

    named soft nofile 4096

    ....and mofity /etc/named.conf in order to add, under the options section:

    files 4096;

    That seems to work. Of course, you may raise the 4096 but I guess that's
    the default in BIND and I was good with that.

    I'm not sure why this happend. Maybe before the update bind had a value of
    1024 for max.sockets and now it was raised to 4096.

    ==================================================
     
Loading...

Share This Page