The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

named has failed, please contact the sysadmin (result was "named is not running").

Discussion in 'General Discussion' started by cz1179, Dec 28, 2004.

  1. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    I get this when restarting or activating nameserver on new cpanel server

    named has failed, please contact the sysadmin (result was "named is not running").

    Ran:
    /scripts/fixndc (same error)
    /scripts/updatenow
    /scripts/rebuildnamedconf
    /scripts/fixnamed

    service named restart
    (blank)

    rndc status
    rndc: connect failed: connection refused

    rndc reload
    rndc: connect failed: connection refused

    pico /etc/rndc.conf
    (checked to make sure rndckey has no hypen, good)

    edit /etc/named.conf
    (blank, shows as "new file")

    touch /etc/namedb/named.conf
    touch: creating `/etc/namedb/named.conf': No such file or directory

    named -v
    BIND 9.2.4rc6

    REINSTALLED PERL MODULES IN WHM:
    DNS::Config::File::Bind9
    Net::Bind

    Updated cPanel to 9.9.9 R-14

    Service manager in whm has nameservers enabled

    Still not working

    I've tried a lot as you can see.
    Anyone can help?
     
  2. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    What does /var/log/messages say when you try to restart Bind?


    also check /etc/rc.conf has

    named_flags="-u bind -c /etc/namedb/named.conf" < or path to named.conf file
     
    #2 easyhoster1, Dec 28, 2004
    Last edited: Dec 28, 2004
  3. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    /var/log/messages shows this when I enabled or restart BIND

    Dec 28 13:12:11 localhost stunnel[5104]: Connection closed: 8839 bytes sent to SSL, 3837 bytes sent to socket


    edit /etc/rc.conf shows as "new file" also
     
  4. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Sounds like Bind did not install correctly. I would do a new install of cpanel and see if that helps. Could be some of the depend files did not get loaded.
     
  5. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    Anyone else know?
     
  6. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    So you have no named.conf file?
    Do you see any other named files in /etc - like named.back, named.conf.back or named.safe?
    If so are there any entries in those files?
    What OS?
     
  7. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Is this the same server your having your other issue with? ( easyapache ) If so, did the perl upgrade fix your issue ?
     
  8. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    this is another server which in fact was freshly reimaged too.

    the other server didn't work...i have no choice but to reimage that as i'm racking out my brains, its not healthy lol
     
  9. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Is this, by chance, a Trustix box? I had some serious bind issues with my Trustix server.
     
  10. aykfounder

    aykfounder Well-Known Member

    Joined:
    Feb 22, 2004
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    I am having a similar problem. ran /scripts/fxndc (not sure the spelling) it didn't work. Trying upcp --force right now and will check for the "-" later. If those don't work, would anyone have any suggestions?

    Thanks
     
  11. aykfounder

    aykfounder Well-Known Member

    Joined:
    Feb 22, 2004
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    NVM, fixed it. For anyone else who's having the same problem. I just did /scripts/upcp --force then ran /scripts/fixndc and it worked.
     
Loading...

Share This Page