The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

named not working properly after cpanel update

Discussion in 'General Discussion' started by hst, Aug 23, 2005.

  1. hst

    hst Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    I get this message every time I restart named

    named has failed, please contact the sysadmin (result was "named is not running"). Aug 23 15:54:45 n21 named: named shutdown failed Aug 23 15:54:46 n21 named[27087]: starting BIND 9.2.4 -u named Aug 23 15:54:46 n21 named[27087]: using 2 CPUs Aug 23 15:54:46 n21 named: named startup succeeded
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Can you please confirm that what was the status of the bind before you start it. Was it failed?. Also did you notice any errors in messages when you restart the bind.
     
  3. hst

    hst Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    modeprobe in messages

    I think bind was OK before update but really hadn't checked. Sites were working OK

    Messages says:
    modeprobe: modprobe: can't locate char-major-10-224
     
  4. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Please try to stop the bind. Then see if it shows any errors the. Also simultaneously check the /var/log/messages
     
  5. hst

    hst Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Here is what I got

    Here is what SSH says:
    root@n21 [~]# /etc/rc.d/init.d/named stop
    Stopping named: /etc/rc.d/init.d/named: line 139: 11370 Segmentation fault /usr/sbin/rndc stop >/dev/null 2>&1
    [FAILED]
    root@n21 [~]#

    Here is in message
    GNU nano 1.2.1 File: /var/log/messages

    Aug 23 18:25:13 n21 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0$
    Aug 23 18:25:13 n21 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Aug 23 18:30:00 n21 modprobe: modprobe: Can't locate module char-major-10-224
    Aug 23 18:30:30 n21 last message repeated 3 times
    Aug 23 18:30:30 n21 sshd(pam_unix)[11239]: session opened for user root by (uid$
    Aug 23 18:30:30 n21 modprobe: modprobe: Can't locate module char-major-10-224
    Aug 23 18:30:46 n21 named: named shutdown failed
     
  6. hst

    hst Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Any ideas

    Any ideas what might be the cause?
     
  7. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Did you try

    /scripts/updatenow
    /scripts/fixndc
     
  8. hst

    hst Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Yes and it didnt work

    Tried both and it didn't help. Still cannot stop named and get fail error
     
  9. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    I am pasting a /etc/rc.d/init.d/named file of redhat machine below. Move your file to a backup and create that file using this code and then check. May be the location of your pid file, the bind user and conf file location are different. You can correct it by checking the named.conf
    --------------------------------------------------------------------
    #!/bin/sh
    #
    # $Id$
    #


    case "$1" in
    start)
    if [ -e /etc/binddisable ]; then
    exit
    fi
    if [ -e /etc/nameddisable ]; then
    exit
    fi
    [ -x /usr/sbin/named ] && /usr/sbin/named -u named -c /etc/named.conf && echo -n ' named'
    ;;
    stop)
    kill `cat /var/run/named/named.pid` && echo -n ' named'
    ;;
    *)
    echo "Usage: `basename $0` {start|stop}" >&2
    exit 64
    ;;
    esac

    exit 0
    --------------------------------------------

    Let me know the status ;)
     
  10. hst

    hst Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Same Error

    Tried your code and code off of another server. Still errors. Says missing modeprobe: module char-major-10-224.
     
  11. ncconquer

    ncconquer Well-Known Member

    Joined:
    Jun 20, 2004
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    same problem
    how to fix this ......... :(
     
  12. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    mv /lib/tls /lib/tls.disable
    service named restart
     
Loading...

Share This Page