The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Named Problems

Discussion in 'General Discussion' started by andrewau, May 4, 2005.

  1. andrewau

    andrewau Member

    Joined:
    Jul 25, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    After CPanel updated (WHM 10.1.0 cPanel 10.2.0-S53 / Trustix i686 - WHM X v3.1.0) bind failed with the error of:
    couldn't open pid file '/var/run/named.pid': Permission

    After some time I found that I needed to add a line in /etc/init.d/named at line numner 79:
    chown ${NAMEDUSER:-named}.${NAMEDGROUP:-named} ${JAIL_BASE}/var/run

    Then after restarting named bind was working. However on the next evening the server must have updated again and the line was removed, thus bind failed. Did the same again and fixed. This time I thought I would change the permissions /etc/init.d/named to 555 so that it could not be changed. However same again the file was changed or replaced.

    How do I stop this from reoccuring.

    Thanks in advance.
    Andrew
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If trustic uses a chroot named you should check in /etc/sysconfig/named and comment out the line:

    ROOTDIR=/var/named/chroot

    Then try restarting named.
     
  3. andrewau

    andrewau Member

    Joined:
    Jul 25, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    This is what I have in /etc/sysconfig/named

    Not sure what to do here

    # Setup file for named
    # Do you want to use the chroot jail for bind? Anything but "no" means yes
    USE_JAIL=yes
    # Where do you want the jail
    CHROOT_BASE="/var/lib/named"
    JAIL_BASE="${CHROOT_BASE}/chroot"
    PROG=named
    NAMEDUSER=named
    NAMEDGROUP=named
    NAMEDCONF="/etc/named.conf"
    NAMEDOPTIONS="-u ${NAMEDUSER} -c ${NAMEDCONF}"

    Andrew
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try setting this:

    USE_JAIL=no
     
Loading...

Share This Page