jerrybell

Well-Known Member
Nov 27, 2006
90
0
156
I am running:cPanel 11.25.0-R46156 - WHM 11.25.0 - X 3.9
FREEBSD 8.1 amd64

This is a fresh install. I see that named is attempted to start in 3 places:
by cpanel
by rc.conf
in /usr/local/etc/rc.d

I have been trying to get down to one version running, and have been mostly successful, but chkservd keeps restarting named every 5 minutes, despite named actually running without a problem. I believe I have narrowed the problem down to an issue with rndc, but I am not sure why it's a problem or how to fix it. In /var/log/messages, I see endlessly repeating instances of this:
Jun 13 15:46:18 www3 named[57240]: stopping command channel on 127.0.0.1#953
Jun 13 15:46:18 www3 named[57240]: exiting
Jun 13 15:46:18 www3 named[57488]: starting BIND 9.6.2-P2
Jun 13 15:46:18 www3 named[57488]: built with '--prefix=/usr' '--infodir=/usr/share/info' '--mandir=/usr/share/man' '--enable-threads' '--disable-ipv6' '--enable-getifaddrs' '--disable-linux-caps' '--with-openssl=/usr' '--with-randomdev=/dev/random' '--without-idn' '--without-libxml2'
Jun 13 15:46:18 www3 named[57488]: command channel listening on 127.0.0.1#953
Jun 13 15:46:18 www3 named[57488]: running
Jun 13 15:51:19 www3 named[57488]: stopping command channel on 127.0.0.1#953
Jun 13 15:51:19 www3 named[57488]: exiting
Jun 13 15:51:19 www3 named[57722]: starting BIND 9.6.2-P2
Jun 13 15:51:19 www3 named[57722]: built with '--prefix=/usr' '--infodir=/usr/share/info' '--mandir=/usr/share/man' '--enable-threads' '--disable-ipv6' '--enable-getifaddrs' '--disable-linux-caps' '--with-openssl=/usr' '--with-randomdev=/dev/random' '--without-idn' '--without-libxml2'
Jun 13 15:51:19 www3 named[57722]: command channel listening on 127.0.0.1#953
Jun 13 15:51:19 www3 named[57722]: running

In /var/log/chkservd.log, I see:
Service Check Started
[2010-06-13 16:06:22 -0400] Service check ....syslogd [[check command:+][tcp connect:N/A]]...sshd [[check command:+][tcp connect:N/A]]...spamd [[check command:+][tcp connect:N/A]]...queueprocd [[check command:+][tcp connect:N/A]]...pop [[check command:N/A][tcp connect:+]]...named [[check command:-][tcp connect:N/A]Restarting named....


I have tried running:
/scripts/setupnameserver --force bind
/scripts/fixrndc --force

In /usr/local/cpanel/logs/error_log, I have the following errors:

[2010-06-13 15:03:53 -0400] warn [fixrndc] /usr/sbin/rndc status failed (Unable to parse output): rndc: connection to remote host closedThis may indicate that* the remote server is using an older version of the command protocol,* this host is not authorized to connect,* the clocks are not synchronized, or* the key is invalid. at /scripts/cPScript/DNSLib.pm line 265
cPScript::DNSLib::checkrndc(cPScript::DNSLib=HASH(0x801d60738)) called at /scripts/fixrndc line 430
[2010-06-13 15:09:38 -0400] warn [fixrndc] /usr/sbin/rndc status failed (Unable to parse output): rndc: connection to remote host closedThis may indicate that* the remote server is using an older version of the command protocol,* this host is not authorized to connect,* the clocks are not synchronized, or* the key is invalid. at /scripts/cPScript/DNSLib.pm line 265
cPScript::DNSLib::checkrndc(cPScript::DNSLib=HASH(0x801d5f750)) called at /scripts/fixrndc line 430


It appears from the error that the problem is that cpanel isn't parsing the output of rndc properly. I haven't found how cpanel is calling rndc to perform the check, but the output when run manually looks like this:
www3# rndc status
version: 9.6.2-P2
CPUs found: 8
worker threads: 8
number of zones: 89
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/0/1000
tcp clients: 0/100
server is up and running


Any ideas on what I can do to fix this problem?

Thanks,

Jerry