Picturebook

Registered
Dec 26, 2009
3
0
51
Hallo Community,

ich habe Probleme bei der Einrichtung der Nameserver in Verbindung mit dem, bei der Vorinstallation vergebenen Hostnamen. Ich erkläre kurz um was es geht:

1. Rootserver mit WHM/cPanel

Bei Order des Servers habe ich den gewünschten Hostnamen mit server angegeben, als Hauptdomain sei bla-blie-blub.com angenommen.

ergo:

server.bla-blie-blub.com

Nun gibt es die Domain bla-blie-blub.com tatsächlich als Domain auf einen entfernten Server Diese Domain gehört mir auch, ist aber nur Gast auf dieser Maschine. Dort befindet sich auch Content.

Nun habe ich nachträglich noch eine Domain beim Serveranbieter geordert, welche bis auf die "-" identisch ist, also blablieblub.com. Auf diese Domain möchte ich in naher Zeit umswitchen, die alte bla-blie-blub.com soll später nur noch als Forwarder verwendet werden.

Als Nameserver habe ich im WHM die beiden Nameserver:

ns1.bla-blie-blub.com
ns2.bla-blie-blub.com


entfernt und neue Zonen angelegt:

ns1.blablieblub.com
ns2.blablieblub.com


welche ich auch beim Domainrobot bzw. Registrar angegeben habe.

Weiterhin habe ich noch eine Zonendatei für die Domain selbst angelegt:

blablieblub.com

aber die

server.bla-blie-blub.com

stehen lassen und auch einen Account angelegt, welcher die Domain blablieblub.com aufnehmen soll. Ihr ahnt es schon: Ich kann diese nicht auflösen bzw. erreichen :rolleyes:

Ich vermute, es liegt am Hostnamen des neuen Servers(server.blablieblub.com) selbst, der immer wieder auf die Hauptdomain (quasi die, welche nur Gast auf einen anderen Server ist) zeigt.
Nun könnte man einfach den Hostnamen an die Domain blablieblub.com anpassen, quasi:

server.blablieblub.com

dann hätte man nicht diesen Kuddelmuddel. Das Problem sind die ServerZertifikate, die dann ja ungültig werden.

Unter Main >> DNS Functions >> Edit DNS Zone > "Choose a Zone to Edit" sind derzeit folgenden Zonen eingerichtet:

Code:
[B]blablieblub.com
ns1.blablieblub.com
ns1.blablieblub.com
server.bla-blie-blub.com[/B]
Wie müsste die Datei:

Code:
/etc/resolv.conf
aussehen?

Code:
[B]search blablieblub.com 
nameserver 111.111.111.111
nameserver 222.222.222.222
[/B]
oder:

Code:
[B]search bla-blie-blub.com 
nameserver 111.111.111.111
nameserver 222.222.222.222
[/B]
??

Was habe ich übersehen bzw. wo liegt der Denkfehler?

Bedingung: Die Alte Domain, also die, wo mom. noch ganz regulärer Content läuft, kann ich nicht auf den neuen Server transferieren! Dieser Content muss hochverfügbar bleiben. Eine Übertragung ist vorerst ausgeschlossen.
 

Pixelpirat

Well-Known Member
Jun 6, 2006
79
0
156
Germany
Hi,

irgendwie scheinst Du etwas durcheinander zu bringen.

Der Nameserver, der die Domain bla-blie-blub.com verwaltet muß auch die Zone für server.bla-blie-blub.com verwalten. Sonst geht das nicht.

Dann ist auch server.bla-blie-blub.com erreichbar.

HTH

Pixelpirat
 

Picturebook

Registered
Dec 26, 2009
3
0
51
In der Tat habe ich so einiges durcheinander gebracht, allerdings habe ich nun
alles auf eine Domain.tld umgestellt, die Servercertifikate erneuert und die Nameserver (eigene) neu eingerichtet. Es funktioniert aber trotzdem nicht, sprich, die Nameserver machen Probleme.

Die Zonen habe ich mit dem WHM - DNS - Manager angelegt:

domain.tld <- wurde automatisch durch neuen Account angelegt
ns1.domain.tld
ns2.domain.tld
server.domain.tld

ns1.domain.tld und ns2.domain.tld beim Registrar eingetragen.

Robtex:

Hier gibt es eine Anleitung, welche beschreibt, wie man eigene Nameserver mittels WHM/cPanel einrichtet. bzw. in welchen config.conf was zu finden ist.
Das entspricht etwa meiner Konstellation. Ich habe mich dabei an Punkt 10. -> 10. Manuell als Root Nameserver anlegen gehalten. Hier eine weitere Beschreibung

Robtex: -> domain.tld
Code:
	+-a.gtld-servers.net (192.5.6.30)
	| 	+-b.gtld-servers.net (192.33.14.30)
	| 	| 	+-c.gtld-servers.net (192.26.92.30)
	| 	| 	| 	+-d.gtld-servers.net (192.31.80.30)
	| 	| 	| 	| 	+-e.gtld-servers.net (192.12.94.30)
	| 	| 	| 	| 	| 	+-f.gtld-servers.net (192.35.51.30)
	| 	| 	| 	| 	| 	| 	+-g.gtld-servers.net (192.42.93.30)
	| 	| 	| 	| 	| 	| 	| 	+-h.gtld-servers.net (192.54.112.30)
	| 	| 	| 	| 	| 	| 	| 	| 	+-i.gtld-servers.net (192.43.172.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-j.gtld-servers.net (192.48.79.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-k.gtld-servers.net (192.52.178.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-l.gtld-servers.net (192.41.162.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-m.gtld-servers.net (192.55.83.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	
ns1.domain.tld	a	xx.xx.xx.01	g	g	g	g	g	g	g	g	g	g	g	g	g	
ns2.domain.tld	a	xx.xx.xx.02	g	g	g	g	g	g	g	g	g	g	g	g	g	
domain.tld	ns	ns2.domain.tld	X	X	X	X	X	X	X	X	X	X	X	X	X	
domain.tld	ns	ns1.domain.tld	X	X	X	X	X	X	X	X	X	X	X	X	X
ns1.domain.tld
Code:
	+-a.gtld-servers.net (192.5.6.30)
	| 	+-b.gtld-servers.net (192.33.14.30)
	| 	| 	+-c.gtld-servers.net (192.26.92.30)
	| 	| 	| 	+-d.gtld-servers.net (192.31.80.30)
	| 	| 	| 	| 	+-e.gtld-servers.net (192.12.94.30)
	| 	| 	| 	| 	| 	+-f.gtld-servers.net (192.35.51.30)
	| 	| 	| 	| 	| 	| 	+-g.gtld-servers.net (192.42.93.30)
	| 	| 	| 	| 	| 	| 	| 	+-h.gtld-servers.net (192.54.112.30)
	| 	| 	| 	| 	| 	| 	| 	| 	+-i.gtld-servers.net (192.43.172.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-j.gtld-servers.net (192.48.79.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-k.gtld-servers.net (192.52.178.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-l.gtld-servers.net (192.41.162.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-m.gtld-servers.net (192.55.83.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	
ns2.domain.tld	a	xx.xx.xx.01	g	g	g	g	g	g	g	g	g	g	g	g	g	
domain.tld	ns	ns2.domain.tld	d	d	d	d	d	d	d	d	d	d	d	d	d	
domain.tld	ns	ns1.domain.tld	d	d	d	d	d	d	d	d	d	d	d	d	d	
ns1.domain.tld	a	xx.xx.xx.02	X	X	X	X	X	X	X	X	X	X	X	X	X
analog dazu:

ns2.domain.tld
Code:
delegation information (beta) for ns2.callintv.net
	+-a.gtld-servers.net (192.5.6.30)
	| 	+-b.gtld-servers.net (192.33.14.30)
	| 	| 	+-c.gtld-servers.net (192.26.92.30)
	| 	| 	| 	+-d.gtld-servers.net (192.31.80.30)
	| 	| 	| 	| 	+-e.gtld-servers.net (192.12.94.30)
	| 	| 	| 	| 	| 	+-f.gtld-servers.net (192.35.51.30)
	| 	| 	| 	| 	| 	| 	+-g.gtld-servers.net (192.42.93.30)
	| 	| 	| 	| 	| 	| 	| 	+-h.gtld-servers.net (192.54.112.30)
	| 	| 	| 	| 	| 	| 	| 	| 	+-i.gtld-servers.net (192.43.172.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-j.gtld-servers.net (192.48.79.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-k.gtld-servers.net (192.52.178.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-l.gtld-servers.net (192.41.162.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	+-m.gtld-servers.net (192.55.83.30)
	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	| 	
ns1.domain.tld	a	xx.xx.xx.01	g	g	g	g	g	g	g	g	g	g	g	g	g	
domain.tld	ns	ns2.domain.tld	d	d	d	d	d	d	d	d	d	d	d	d	d	
domain.tld	ns	ns1.domain.tld	d	d	d	d	d	d	d	d	d	d	d	d	d	
ns2.domain.tld	a	xx.xx.xx.02	X	X	X	X	X	X	X	X	X	X	X	X	X
Fehlen etwa PTR-Records in den NS-Zonen? Ich stehe nach mehreren Nächten, die ich mit der Fehlersuche zugebracht habe, völlig auf dem Schlauch.

Gruss

Picturebook
 

Pixelpirat

Well-Known Member
Jun 6, 2006
79
0
156
Germany
Domain domain.tld ist eine echte Domain und hat in wirklichkeit das "tld" nicht am Ende.

Wer sind die Domainrootserver der Domain die bei der Registrierung angegeben wurden?

Was wirft den "dig NS domain.tld" raus
Einmal auf der Maschine ausgeführt und einmal auf Deinem Rechner.

Poste mal bitte die ganze Zone mit allen Einträgen.

Gruß
Pixelpirat
 
Last edited:

Picturebook

Registered
Dec 26, 2009
3
0
51
Hat sich erledigt, man hatte dem Server falsche IP's zugewiesen.
Ich hatte also keine Chance :rolleyes: Jetzt läuft er wie geplant.

Picturebook