The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nameserver Dns Problems Killing Me

Discussion in 'Bind / DNS / Nameserver Issues' started by gregorydlc, Oct 28, 2007.

  1. gregorydlc

    gregorydlc Registered

    Joined:
    Oct 23, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I've never had this problem on shared hosting but now that I have a dedicated server I cannot for the life of me figure out how to fix this. I've pointed the domain names to the proper nameservers. According to the hosting provider:

    We have already setup your hostname, nameservers and additional
    allocated IP addresses on your server for you (assuming you have a control
    panel). We have also setup a reverse PTR DNS record for your primary IP
    already to your hostname.

    Server IP Address: 66.79.164.68
    Server Hostname: server.bluehost.com

    Primary Nameserver: ns1.bluehost.com
    Primary Nameserver IP: 66.79.164.68
    Secondary Nameserver: ns2.bluehost.com
    Secondary Nameserver IP: 66.79.181.16

    here is a copy of my named.conf file:






    [root@server etc]# vi named.conf




    include "/etc/rndc.key";

    controls {
    inet 127.0.0.1 allow { localhost; } keys { "rndckey"; };
    };

    //
    // named.conf for Red Hat caching-nameserver
    //

    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    allow-recursion {
    127.0.0.1;
    205.209.190.5;
    205.209.190.4;
    66.79.162.0/24;
    66.79.163.0/24;
    66.79.164.0/24;
    66.79.165.0/24;
    66.79.166.0/24;
    66.79.178.0/24;
    66.79.179.0/24;
    66.79.168.0/24;
    66.79.180.0/24;
    66.79.183.0/24;
    66.79.184.0/24;
    66.79.185.0/24;
    66.79.186.0/24;
    66.79.189.0/24;
    66.79.188.0/24;
    66.79.190.0/24;
    66.79.191.0/24;
    66.79.185.0/24;
    66.79.167.0/24;
    66.79.181.0/24;
    66.79.182.0/24;
    66.79.171.0/24;
    };
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //

    zone "." IN {
    type hint;
    file "/var/named/named.ca";
    };

    zone "localdomain" IN {
    type master;
    file "/var/named/localdomain.zone";
    allow-update { none; };
    };

    zone "localhost" IN {
    type master;
    file "/var/named/localhost.zone";
    allow-update { none; };
    };

    zone "0.0.127.in-addr.arpa" IN {
    type master;
    file "/var/named/named.local";
    allow-update { none; };
    };

    zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
    type master;
    file "/var/named/named.ip6.local";
    allow-update { none; };
    };

    zone "255.in-addr.arpa" IN {
    type master;
    file "/var/named/named.broadcast";
    allow-update { none; };
    };

    zone "0.in-addr.arpa" IN {
    type master;
    file "/var/named/named.zero";
    allow-update { none; };
    };





    zone "server.bluehost.com" {
    type master;
    file "/var/named/server.bluehost.com.db";
    };


    zone "ns1.bluehost.com" {
    type master;
    file "/var/named/ns1.bluehost.com.db";
    };


    zone "ns2.bluehost.com" {
    type master;
    file "/var/named/ns2.bluehost.com.db";
    };




    zone "accident-news.info" {
    type master;
    file "/var/named/accident-news.info.db";
    };


    zone "automobile-news.info" {
    type master;
    file "/var/named/automobile-news.info.db";
    };


    zone "easyhostguide.com" {
    type master;
    file "/var/named/easyhostguide.com.db";
    };




    Can anyone figure how to get the domain names to resolve?
     
  2. nicnicy

    nicnicy Member

    Joined:
    Apr 19, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    had same isue today

    this helped me today, reinstall to CentOS 5 (RH clone) Cpanel11
    works fine now

    Code:
    I have come accross an issue with DNS in cpanel 11.x , where named.conf is badly configured by cpanel ,
    
    Here is how a DNS report from dnsstuff.com would look because of this :
    
    FAILS for SOA record
    Fails for lame nameservers .
    
    Here's how to fix it ,
    
    SSH to server ,
    
    Backup your named.conf file by
    
    cp /etc/named.conf named.conf.back
    
    then
    pico /etc/named.conf
    
    Replace
    
    Code:
    
    include "/etc/rndc.key";
    
    controls {
    inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
    };
    
    options
    {
    /* make named use port 53 for the source of all queries, to allow
    * firewalls to block all ports except 53:
    */
    query-source port 53; 
    
    // Put files that named is allowed to write in the data/ directory:
    directory "/var/named"; // the default
    dump-file "data/cache_dump.db";
    statistics-file "data/named_stats.txt";
    memstatistics-file "data/named_mem_stats.txt";
    };
    
    logging 
    {
    /* If you want to enable debugging, eg. using the 'rndc trace' command,
    * named will try to write the 'named.run' file in the $directory (/var/named).
    * By default, SELinux policy does not allow named to modify the /var/named directory,
    * so put the default debug log file in data/ :
    */
    channel default_debug {
    file "data/named.run";
    severity dynamic;
    }; 
    };
    
    // All BIND 9 zones are in a "view", which allow different zones to be served
    // to different types of client addresses, and for options to be set for groups
    // of zones.
    //
    // By default, if named.conf contains no "view" clauses, all zones are in the 
    // "default" view, which matches all clients.
    // 
    // If named.conf contains any "view" clause, then all zones MUST be in a view; 
    // so it is recommended to start off using views to avoid having to restructure
    // your configuration files in the future.
    
    view "localhost_resolver"
    {
    /* This view sets up named to be a localhost resolver ( caching only nameserver ).
    * If all you want is a caching-only nameserver, then you need only define this view:
    */
    match-clients { localhost; };
    match-destinations { localhost; };
    recursion yes;
    
    zone "." IN {
    type hint;
    file "/var/named/named.ca";
    };
    
    /* these are zones that contain definitions for all the localhost
    * names and addresses, as recommended in RFC1912 - these names should
    * ONLY be served to localhost clients:
    */
    include "/var/named/named.rfc1912.zones";
    };
    
    view "internal"
    {
    /* This view will contain zones you want to serve only to "internal" clients
    that connect via your directly attached LAN interfaces - "localnets" .
    */
    match-clients { localnets; };
    match-destinations { localnets; };
    recursion yes;
    
    zone "." IN {
    type hint;
    file "/var/named/named.ca";
    };
    
    // include "/var/named/named.rfc1912.zones";
    // you should not serve your rfc1912 names to non-localhost clients.
    
    // These are your "authoritative" internal zones, and would probably
    // also be included in the "localhost_resolver" view above :
    };
    
    view "external"
    {
    /* This view will contain zones you want to serve only to "external" clients
    * that have addresses that are not on your directly attached LAN interface subnets:
    */
    match-clients { !localnets; !localhost; };
    match-destinations { !localnets; !localhost; };
    
    recursion no;
    // you'd probably want to deny recursion to external clients, so you don't
    // end up providing free DNS service to all takers
    
    // all views must contain the root hints zone:
    zone "." IN {
    type hint;
    file "/var/named/named.ca";
    };
    
    // These are your "authoritative" external zones, and would probably
    // contain entries for just your web and mail servers:
    
    // BEGIN external zone entries
    
    With
    
    Code:
    
    include "/etc/rndc.key";
    
    controls {
    inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
    };
    
    And then goto bottom of the file and remove
    
    }; at the bottom .
    
    Save file and exit
    
    then test config
    service named configtest
    if you have done this correctly , it should display something like this:
    
    zone blue.xxx.com/IN: loaded serial 2007070901
    zone xxx.com/IN: loaded serial 2007070906
    zone ns1.xxx.com/IN: loaded serial 2007070901
    zone server.xxx.com/IN: loaded serial 2007071001
    zone xxx.net/IN: loaded serial 2007071001
    
    Then restart named by
    
    service named restart
    
    Thats it! , your DNS should be working now .
    
    This fix was provided by Tech4server.com
    
    
    --------------------------------------------------------------------------------
    
    
     
  3. Starcraftmazter

    Starcraftmazter Well-Known Member

    Joined:
    May 5, 2006
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Damnit, reinstalling is fine unless you have a ton of stuff on the server ><
     
Loading...

Share This Page