The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nameserver installation fails!

Discussion in 'Bind / DNS / Nameserver Issues' started by Xenon101, Oct 4, 2005.

  1. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Bind fails due to incorrect named.conf, dunno why!!

    Code:
    Name Server Activated
    Ensuring caching-nameserver is installed
    Using RPM Backend: RPM version 4.2.3
    Fetching rpm updates list...Error 404 while fetching url [url]http://updates.cpanel.net//pub/rpminstall/redhat-3.4/updates.x86.v2.db.gz.md5[/url]
    This could indicate you have not properly configured an update source:
    To select an update source create a file in /var/cpanel called use[sourcename]
    For example:
       /var/cpanel/useyum - Yum (CentOS,Fedora)
       /var/cpanel/useup2date - U2pdate (RHEL)
       /var/cpanel/useswup - SWUP (Trustix)
       /var/cpanel/userug - Rug (SuSE)
       /var/cpanel/useapt - Apt-Get (Debian)
       /var/cpanel/useemerge - Portage (Gentoo)
    
    This is the error I'm getting when trying to install the nameserver for the first time. Note the URL it's trying to fetch has "redhat-3.4" in it (which im guessing is because im using CentOS 3.4), however that folder doesn't actually exist on the cpanel updates http server. I think this is a problem with a cpanel script that may need their guys to sort out but if theres a quick fix i wouldnt mind finding it out!
     
    #1 Xenon101, Oct 4, 2005
    Last edited: Oct 5, 2005
  2. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Bind fails due to incorrect named.conf, dunno why!!

    Ok so i got bored and went to find ISC Bind's website and found it. Totally removed bind 9.2.4 and installed bind 9.2.5 with all the dependencies. It's just installed now and i'm trying to start but getting a few errors.

    Code:
    Starting named: /etc/rndc.key:4: missing ';' before '}'
    
    Oct 05 11:24:03.407 starting BIND 9.2.5 -g
    Oct 05 11:24:03.407 using 4 CPUs
    Oct 05 11:24:03.412 loading configuration from '/etc/named.conf'
    Oct 05 11:24:03.412 /etc/rndc.key:4: missing ';' before '}'
    Oct 05 11:24:03.412 loading configuration: failure
    Oct 05 11:24:03.412 exiting (due to fatal error)
    Error in configuration file /etc/named.conf :              [FAILED]
    This is my named.conf:
    Code:
    include "/etc/rndc.key";
    
    controls {
            inet 127.0.0.1 allow { localhost; } keys { "rndckey"; };
    };
    
    //
    // named.conf for Red Hat caching-nameserver
    //
    
    options {
            directory "/var/named";
            dump-file "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            /*
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
             */
             // query-source address * port 53;
    };
    
    //
    // a caching only nameserver config
    //
    
    zone "." IN {
           type hint;
            file "/var/named/named.ca";
    };
    
    zone "localdomain" IN {
            type master;
            file "/var/named/localdomain.zone";
            allow-update { none; };
    };
    zone "localhost" IN {
            type master;
            file "/var/named/localhost.zone";
            allow-update { none; };
    };
    
    zone "0.0.127.in-addr.arpa" IN {
            type master;
            file "/var/named/named.local";
            allow-update { none; };
    zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" I$
            type master;
            file "/var/named/named.ip6.local";
            allow-update { none; };
    };
    
    zone "255.in-addr.arpa" IN {
            type master;
            file "/var/named/named.broadcast";
            allow-update { none; };
    };
    
    zone "0.in-addr.arpa" IN {
            type master;
            file "/var/named/named.zero";
            allow-update { none; };
    };
    zone "***HOSTNAME***" {
            type master;
            file "/var/named/***HOSTNAME***.db";
    };
    
    
    Anyone see where i've gone wrong?
     
    #2 Xenon101, Oct 5, 2005
    Last edited: Oct 5, 2005
  3. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    I thiink the first issue was due to the corrupted rpm database. Can you try rebuilding the rpm db. Then try installing the bind usind /scripts/fixndc --force as the cpanel default. That should solve your named issue.
     
  4. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    unfortunately there is no rpm's database :/ every time i click rebuild it says complete but theres no rpm's in the list on 'install a rpm' so im kinda stumped...
     
  5. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    hmm that's weird...i seem to have fixed it, by doing /scripts/fixndc twice after editting named.conf & rndc.key & root.hints with help from a site :) yay!
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    With regards to the OS updates problem. If you're using CentOS then you should be using yum, make sure that the following file exists and if it doesn't, just create it as an empty file:

    /var/cpanel/useyum

    then try running:

    /scripts/sysup
     
Loading...

Share This Page