drhamad

Member
Aug 19, 2005
22
0
151
I'm having some pretty annoying issues with subdomains right now. One of my customers has mail.theirdomain.net pointed to http://www.theirdomain.net:2095/3rdparty/squirrelmail/src/login.php
Yet instead, the domain is going to https://www.phoenixcr.net:2083/3rdparty/squirrelmail/src/login.php
Meanwhile, their secondary domain is working just fine.

It seems to me, because of some other subdomain problems that are similar, with this client, that the subdomain redirection is not changing when a new URL is saved. So they probably screwed it up the first time, and now it won't change to the correct one (2095).
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,466
31
473
Go on, have a guess
That's because mail.theirdomain.com is not a web address. It's an A entry for email use. If you want users to be allowed to use mail.theirdomain.com you will either need to set that up as a specified subdomain within cPanel or add it as a ServerAlias in httpd.conf.
 

drhamad

Member
Aug 19, 2005
22
0
151
chirpy said:
That's because mail.theirdomain.com is not a web address. It's an A entry for email use. If you want users to be allowed to use mail.theirdomain.com you will either need to set that up as a specified subdomain within cPanel or add it as a ServerAlias in httpd.conf.
Well now don't I feel silly. It actually did/does work (I did not set it up, they did, which is why i have no experience with anyone trying that before), just doesn't change.

Thanks for the info though, I'll keep that in mind. I'll let them know.