The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nameserver Issues

Discussion in 'Bind / DNS / Nameserver Issues' started by canadiancow, Sep 14, 2007.

  1. canadiancow

    canadiancow Active Member

    Joined:
    Jul 7, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I've setup my server, but when I try to connect to any configured hosts, the nameserver won't respond.

    You can see the message if you try to lookup www.utterlyhosting.com (nameservers are ns1. and ns2.utterlyhosting.com)

    On my other cPanel server, I didn't have to do any special configuration; it just worked, so I have no idea what to do here.
     
  2. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    I did a dnsreport on your domain. Seems that you are missing NS entries for the nameservers. Add them and restart bind.
     
  3. canadiancow

    canadiancow Active Member

    Joined:
    Jul 7, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I've attached a screenshot of the utterlyhosting.com DNS zone (the only one setup so far).

    It matches what I have on another server (but a different domain), and that one works fine.

    When I click save, it says (among other good looking messages): "Reconfiguring Local Mail: This server will NOT serve as a mail exchanger for utterlyhosting.com's mail."
     

    Attached Files:

    • dns.JPG
      dns.JPG
      File size:
      170.6 KB
      Views:
      102
  4. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    Interesting, entries look fine. Did you do a check of named.conf and see if it turns out ok ?
     
  5. canadiancow

    canadiancow Active Member

    Joined:
    Jul 7, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    named.conf has:
    Code:
            zone "utterlyhosting.com" {
                    type master;
                    file "/var/named/utterlyhosting.com.db";
            };
    
    and /var/named/utterlyhosting.com.db has:
    Code:
    [root@alpha ~]# cat /var/named/utterlyhosting.com.db
    ; Modified by Web Host Manager
    ; Zone File for utterlyhosting.com
    $TTL 14400
    @       86400   IN      SOA     ns1.utterlyhosting.com. skennedy.kennedycode.com.       (
                                            2007091405
                                            86400
                                            7200
                                            3600000
                                            86400
                                            )
    
    utterlyhosting.com.     86400   IN      NS      ns1.utterlyhosting.com.
    utterlyhosting.com.     86400   IN      NS      ns2.utterlyhosting.com.
    
    ns2.utterlyhosting.com. 14400   IN      A       208.53.160.226
    ns1.utterlyhosting.com. 14400   IN      A       66.90.104.139
    
    utterlyhosting.com.     14400   IN      A       66.90.104.139
    
    localhost.utterlyhosting.com.   14400   IN      A       127.0.0.1
    
    utterlyhosting.com.     14400   IN      MX      0       utterlyhosting.com.
    
    mail    14400   IN      CNAME   utterlyhosting.com.
    www     14400   IN      CNAME   utterlyhosting.com.
    ftp     14400   IN      A       66.90.104.139
    alpha   14400   IN      A       66.90.104.139
    
     
  6. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    Can you post the first 100 lines from named.conf ?
     
  7. canadiancow

    canadiancow Active Member

    Joined:
    Jul 7, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Here's the whole thing:
    Code:
    [root@alpha ~]# cat /etc/named.conf
    include "/etc/rndc.key";
    
    controls {
            inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
    };
    
    
    options
    {
        /* make named use port 53 for the source of all queries, to allow
             * firewalls to block all ports except 53:
             */
        query-source    port 53;
    
        // Put files that named is allowed to write in the data/ directory:
        directory "/var/named"; // the default
        dump-file             "data/cache_dump.db";
        statistics-file     "data/named_stats.txt";
        memstatistics-file     "data/named_mem_stats.txt";
    };
    
    logging
    {
    /*      If you want to enable debugging, eg. using the 'rndc trace' command,
     *      named will try to write the 'named.run' file in the $directory (/var/named).
     *      By default, SELinux policy does not allow named to modify the /var/named directory,
     *      so put the default debug log file in data/ :
     */
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
    };
    
    
    // All BIND 9 zones are in a "view", which allow different zones to be served
    // to different types of client addresses, and for options to be set for groups
    // of zones.
    //
    // By default, if named.conf contains no "view" clauses, all zones are in the
    // "default" view, which matches all clients.
    //
    // If named.conf contains any "view" clause, then all zones MUST be in a view;
    // so it is recommended to start off using views to avoid having to restructure
    // your configuration files in the future.
    
    view "localhost_resolver"
    {
    /* This view sets up named to be a localhost resolver ( caching only nameserver ).
     * If all you want is a caching-only nameserver, then you need only define this view:
     */
        match-clients         { localhost; };
        match-destinations    { localhost; };
        recursion yes;
    
        zone "." IN {
            type hint;
            file "/var/named/named.ca";
        };
    
        /* these are zones that contain definitions for all the localhost
         * names and addresses, as recommended in RFC1912 - these names should
         * ONLY be served to localhost clients:
         */
        include "/var/named/named.rfc1912.zones";
    };
    
    view "internal"
    {
    /* This view will contain zones you want to serve only to "internal" clients
       that connect via your directly attached LAN interfaces - "localnets" .
     */
        match-clients        { localnets; };
        match-destinations    { localnets; };
        recursion yes;
    
        zone "." IN {
            type hint;
            file "/var/named/named.ca";
        };
    
        // include "/var/named/named.rfc1912.zones";
        // you should not serve your rfc1912 names to non-localhost clients.
    
        // These are your "authoritative" internal zones, and would probably
        // also be included in the "localhost_resolver" view above :
    
    
            zone "utterlyhosting.com" {
                    type master;
                    file "/var/named/utterlyhosting.com.db";
            };
    };
    
    view    "external"
    {
    /* This view will contain zones you want to serve only to "external" clients
     * that have addresses that are not on your directly attached LAN interface subnets:
     */
        match-clients        { !localnets; !localhost; };
        match-destinations    { !localnets; !localhost; };
    
        recursion no;
        // you'd probably want to deny recursion to external clients, so you don't
        // end up providing free DNS service to all takers
    
        // all views must contain the root hints zone:
        zone "." IN {
            type hint;
            file "/var/named/named.ca";
        };
    
        // These are your "authoritative" external zones, and would probably
        // contain entries for just your web and mail servers:
    
        // BEGIN external zone entries
    
    
                    zone "utterlyhosting.com" {
                            type master;
                            file "/var/named/utterlyhosting.com.db";
                    };
    };
    
     
  8. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    Remove some of the lines, and it should look like this :


    I basically removed some lines, unnecessary. Save the file and restart bind.
     
    #8 bin_asc, Sep 14, 2007
    Last edited: Sep 14, 2007
  9. canadiancow

    canadiancow Active Member

    Joined:
    Jul 7, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Code:
    Starting named:
    Error in named configuration:
    /etc/named.conf:48: unexpected end of input
                                                               [FAILED]
    
     
  10. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    They aren`t a real need, but it`s ok if they are there.
     
  11. canadiancow

    canadiancow Active Member

    Joined:
    Jul 7, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I copied my config from my other server, and just deleted all the zones, but added utterlyhosting.com. There are some zones that look like they need to be there, but weren't.

    Code:
    include "/etc/rndc.key";
    
    controls {
            inet 127.0.0.1 allow { localhost; } keys { "rndckey"; };
    };
    
    //
    // named.conf for Red Hat caching-nameserver
    //
    
    options {
            directory "/var/named";
            dump-file "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            /*
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
             */
             // query-source address * port 53;
    };
    
    //
    // a caching only nameserver config
    //
    
    zone "." IN {
            type hint;
            file "/var/named/named.ca";
    };
    
    zone "localdomain" IN {
            type master;
            file "/var/named/localdomain.zone";
            allow-update { none; };
    };
    
    zone "localhost" IN {
            type master;
            file "/var/named/localhost.zone";
            allow-update { none; };
    };
    
    zone "0.0.127.in-addr.arpa" IN {
            type master;
            file "/var/named/named.local";
            allow-update { none; };
    };
    
    zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
            type master;
            file "/var/named/named.ip6.local";
            allow-update { none; };
    };
    
    zone "255.in-addr.arpa" IN {
            type master;
            file "/var/named/named.broadcast";
            allow-update { none; };
    };
    
    zone "0.in-addr.arpa" IN {
            type master;
            file "/var/named/named.zero";
            allow-update { none; };
    };
    
    zone "utterlyhosting.com" {
            type master;
            file "/var/named/utterlyhosting.com.db";
    };
    
     
Loading...

Share This Page