The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nameserver Question

Discussion in 'Bind / DNS / Nameserver Issues' started by fog, Oct 1, 2002.

  1. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    I had a Ensim machine. It was setup to use ns1.domain.com and ns2.domain.com as it's NS and domain.com was a site located on this machine. ns5/ns6 and ns7/ns8 (same root domain) are the NS for my 2 cpanel machines. The Ensim machine has died so I am trying to move domain.com to a cpanel machine which uses ns7.domain.com and ns8.domain.com (same domain).

    I had to add A records to the Ensim machine when I got the cpanel machines with ns7/ns8 and ns5/ns6 pointing to the cpanel machine IPs so these nameservers would work. It took me a bit to figure that out. I guess this was because I needed A records on the machine hosting the root domain.

    My concern is this. I have changed the NS at my registrar so domain.com now points to ns7 and ns8 (the cpanel machine), but I assume I need to add all the A records I had to add to domain.com's zone on the ensim box for ns5/ns6 and ns7/ns8 since I had to do it before to make them work.

    In Ensim adding A records is very easy and I'm sure it is in cpanel as well, but could someone please walk me through this? This is really urgent because if I don't have the A records in place on ns7/ns8 machine I am sure the dns for ns5/ns6 will die once domain.com propogates.

    Please help me with this. I am willing to call someone if that would be easier. Any help is greatly appreciated.
     
  2. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Thanks for the reply. I went in there, but I just want to make sure I am adding the entries correctly...

    1st box I put ns5.domain.com, A record was selected in the drop box, and I entered the IP of the other server in the next box.

    I did the same thing for ns6.

    I then did this for ns7 and ns8 which are the NS for the server I am adding the records to.

    Does that look correct? When I look at the entries made for this zone by WHM... I see whatever.domain.com. instead of ns5.domain.com without a period on the end. The period is throwing me off as well as ensim didn't have those. Thanks again... I'm very nervous about this move and appreciate any help getting me away from Ensim.
     
Loading...

Share This Page